Bug 148633 - LO Help F1 or button cannot open help with Snap browser
Summary: LO Help F1 or button cannot open help with Snap browser
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL: https://community.documentfoundation....
Depends on:
Blocks: Help-Viewer
  Show dependency treegraph
Reported: 2022-04-17 03:56 UTC by robgrune
Modified: 2024-03-08 01:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

screesnshot no help (132.34 KB, image/png)
2022-05-27 10:02 UTC, robgrune

Note You need to log in before you can comment on or make changes to this bug.
Description robgrune 2022-04-17 03:56:23 UTC
Version: / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 6; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Ubuntu package version: 1:7.3.2-0ubuntu2
Calc: threaded
Gnome 42
Ubuntu 22.04
windowing X11
cpu amd fx 6core
LO installed from Ubuntu repositories

When clicking "help" or pressing F1, a new window opens and displays...

<!DOCTYPE HTML><html lang="en-US"><head><meta charset="UTF-8"><noscript><meta http-equiv="refresh" content="0; url='file:///usr/share/libreoffice/help/en-GB/noscript.html'"></noscript><meta http-equiv="refresh" content="1; url='file:///usr/share/libreoffice/help/index.html?Target=swriter/.uno%3AHelpIndex&Language=en-GB&System=UNIX&Version=7.3'"><script type="text/javascript"> window.location.href = "file:///usr/share/libreoffice/help/index.html?Target=swriter/.uno%3AHelpIndex&Language=en-GB&System=UNIX&Version=7.3";</script><title>Help Page Redirection</title></head><body></body></html>

No help function.
Comment 1 Mike Kaganski 2022-04-17 07:13:53 UTC
F1 opens your system's default HTML viewer (typically, a browser), with either online, or locally installed, help. What application opens in your case?
Comment 2 Mike Kaganski 2022-04-17 07:14:54 UTC
(and JavaScript needs to be enabled for the help to work, btw)
Comment 3 robgrune 2022-04-18 00:49:46 UTC
(In reply to Mike Kaganski from comment #2)
> (and JavaScript needs to be enabled for the help to work, btw)

Thanks for reply.

Upon pressing F1, "text editor" opens, displaying the text noted above. 

Many packages are installed relating to java, such as: java-common, javascript-common, ure-java, libunoloader-java, etc. 

What specifically must I know and invoke for java?
Comment 4 Olivier Hallot 2022-04-18 11:31:19 UTC Comment hidden (obsolete)
Comment 5 robgrune 2022-04-19 09:07:52 UTC
(In reply to Olivier Hallot from comment #4)
> Java has no role in Help display and navigation (Java and Javascript are
> different animals)
> LibreOffice uses xdg to invoke HTML viewer (as said, typically a browser).
> If xdg settings for HTML is missing or poorly set, this may be the cause.
> Please review packages installation of xdg in your Ubuntu machine. Hint: you
> should have these kind of programs: 
> xdg-dbus-proxy        
> xdg-desktop-menu      
> xdg-icon-resource     
> xdg-open              
> xdg-settings          
> xdg-user-dirs-update
> xdg-desktop-icon      
> xdg-email

Thanks for reply. Appreciated. Using synaptic, I found the xdg files and re-installed them. 

Now, when I press F1, the script text shown above no longer appears and the browser comes up with an message stating a certain file is not found.
Comment 6 Timur 2022-05-26 13:02:47 UTC Comment hidden (obsolete)
Comment 7 robgrune 2022-05-27 02:48:37 UTC
(In reply to Timur from comment #6)
> That's a different problem.
> Where exactly did you press F1 and what page did you get? 
> Is it the same if you press Help button (rarely doesn't have to be)?

Pressing F1 or Help links to the default browser (could be either Firefox or Chromium) and a page shows with message to the effect no help files found.

The problem is the lack of system integration. Seems LO, FF, Chrome are now 'snap' installs. 

The problem is solved by installing a new browser from the deb repository. I found 'slimjet', and this works perfectly to show the help files.

This help problem is only one of many LO bugs I have discovered. The worst is severe input lag, causing LO to be entirely useless.

LO is no longer the capable, friendly suite is was once upon a time.
Comment 8 QA Administrators 2022-05-27 03:34:32 UTC Comment hidden (obsolete)
Comment 9 Timur 2022-05-27 07:00:43 UTC Comment hidden (obsolete)
Comment 10 Timur 2022-05-27 07:24:07 UTC Comment hidden (obsolete)
Comment 11 robgrune 2022-05-27 10:02:03 UTC
Created attachment 180426 [details]
screesnshot no help
Comment 12 robgrune 2022-05-27 10:03:12 UTC
in any LO app, press F1 or Help menu.
the attached screenshot shows.
Comment 13 Timur 2022-05-27 11:51:20 UTC
(In reply to Timur from comment #10)
> I think I reproduced this when I tested in Ubuntu 22.0 with only snap
> Firefox and Chromium. Both F1 and button. 
> It was slow and finally it tried to open local link only:
> file:///usr/share/libreoffice/help/index.html?....
> I put this to major as snap is now only browser in Ubuntu 22.04. Any install
> from Software is also snap.

Described is most common situation in new Ubuntu, snap browser and regular LO.

There's more. If both browser and LO and snap (like in minimal install and LO added later), F1 opens local help. Maybe because snap installs it.
Comment 14 Buovjaga 2022-05-31 13:03:31 UTC
If it's a Snap issue, the primary feedback channel should be Ubuntu's bug tracker: https://bugs.launchpad.net/ubuntu/+source/libreoffice/
Comment 15 Olivier Hallot 2024-03-07 19:43:20 UTC
(In reply to Buovjaga from comment #14)
> If it's a Snap issue, the primary feedback channel should be Ubuntu's bug
> tracker: https://bugs.launchpad.net/ubuntu/+source/libreoffice/

Also in Mozilla
Comment 16 Stéphane Guillou (stragu) 2024-03-08 01:35:03 UTC
I ran into this after upgrading to Ubuntu 22.04 + GNOME 42.9, with own build of help submodule or installed help pack from.deb, opening in Chromium or Firefox (both snaps).

With Firefox, I get the following message in terminal:

Gtk-Message: 01:59:45.957: Not loading module “atk-bridge”: The functionality is provided by GTK natively. Please try to not load it.

And the page fails to load with:

   File not found
   Firefox can’t find the file at /tmp/lu9130c8gp.tmp/NewHelp3.html.

(that last number gets incremented every time I attempt to open the help)

With Chromium as the default browser, I get this in terminal:

   (chrome:11153): Gtk-WARNING **: 10:59:31.519: GTK+ module /snap/chromium/2768/gnome-platform/usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so cannot be loaded.
   GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.
   Gtk-Message: 10:59:31.519: Failed to load module "canberra-gtk-module"
   [11153:11153:0308/105931.558514:ERROR:policy_logger.cc(157)] :components/enterprise/browser/controller/chrome_browser_cloud_management_controller.cc(161) Cloud management controller initialization aborted as CBCM is not enabled. Please use the `--enable-chrome-browser-cloud-management` command line flag to enable it if you are not using the official Google Chrome build.

And Chromium throws an ERR_FILE_NOT_FOUND on the same tmp file.

I installed Falkon as a .deb from the Ubuntu repos, no problem opening the help files with that as a default.

Similar to https://bugs.launchpad.net/snapd/+bug/1773416