Bug 148637 - Unusably tiny window size after 'restore' is used on KDE
Summary: Unusably tiny window size after 'restore' is used on KDE
Status: RESOLVED DUPLICATE of bug 125543
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-17 13:33 UTC by BDF
Modified: 2022-04-26 06:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Tiny LibreOffice window after 'retore' is used (1.38 MB, image/png)
2022-04-17 13:35 UTC, BDF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BDF 2022-04-17 13:33:19 UTC
Description:
I was using calc and clicked on the window control 'restore' in the top right corner. The Window was resized to an unusably small size. The only visible UI element in there was the close button.

Steps to Reproduce:
1. Open LO window in Dolphin (KDE)
2. Click 'restore' button

I have no idea if this error would turn up more than once. Maybe this will never turn up again if a minimum window size is set.

Actual Results:
The window turns unusably small

Expected Results:
A leave a minimum Window size with at least the 'maximise' and 'close' UI elements visible.
A better idea would may be to have a minimum window size with some content.


Reproducible: Couldn't Reproduce


User Profile Reset: No



Additional Info:
- See attached image
- I reported this in the KDE bugtracker as well since I have no idea what this behaviour is caused by: https://bugs.kde.org/show_bug.cgi?id=452700

------------------------------------------------------------

Version: 7.3.2.2 / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: de-AT (de_AT.UTF-8); UI: de-DE
Flatpak
Calc: threaded

------------------------------------------------------------

Operating System: KDE neon 5.24
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.13.0-39-generic (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 4800H with Radeon Graphics
Memory: 30.8 GiB of RAM
Graphics Processor: AMD RENOIR
Comment 1 BDF 2022-04-17 13:35:27 UTC
Created attachment 179626 [details]
Tiny LibreOffice window after 'retore' is used

The window of LibreOffice in the top left corner is scaled down and no content is visible. Only the close button is left.
Comment 2 BDF 2022-04-17 13:37:17 UTC
The "workaround" is of course to manually resize the Window. Duhh, right?

It was an unexpected behaviour and first I thought that LibreOffice crashed. Then I wasn't sure what really did happen. After I closed and reopened calc I saw the leftover from the windows in the top left corner.
Comment 3 BDF 2022-04-25 21:35:06 UTC
Bug report on the KDE bug tracker got closed by Nate Graham: "It really sounds like a LibreOffice bug"
Comment 4 draco31.fr 2022-04-26 06:45:12 UTC
Hello,

I encounter the same behavior with Calc on Ubuntu Budgie and Xubuntu (Xfce desktop).
So I don't think its related to KDE.

IMHO it is a duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=125543
Comment 5 draco31.fr 2022-04-26 06:50:30 UTC

*** This bug has been marked as a duplicate of bug 125543 ***