Bug 148698 - Siebar: Margin settings incorrect for letter size incorrect at the page tab
Summary: Siebar: Margin settings incorrect for letter size incorrect at the page tab
Status: RESOLVED DUPLICATE of bug 135572
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Page
  Show dependency treegraph
 
Reported: 2022-04-21 04:57 UTC by Eek! A Bug. Kill it!
Modified: 2022-04-25 15:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eek! A Bug. Kill it! 2022-04-21 04:57:22 UTC
Description:
The Page Format Margins settings are incorrect for the Letter Size as used in the United States (which is 8.5" × 11.0") when the Normal (0.75") Margin is selected. In other words, for this setting, the margins should be set at 0.75" and 7.75". For rulers, I use points – not inches, so the Normal Margins setting should be 54 pts for the left margin and 504 pts for the right margin. Instead, the left margin is set to 57 pts (~0.7916") and the right margin at 498 pts (~6.916"). 

NOTE: The workaround for users from the United States is to avoid the Normal (0.75") setting and use the Moderate Margin setting, but this should not be necessary for obvious reasons.

Steps to Reproduce:
1. Select Letter with Normal (0.75") Margins

Actual Results:
Letter size is incorrect by amount described above in Description section.

Expected Results:
Letter size to reflect proper settings.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.3.2.2 (x64) / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 1 Telesto 2022-04-21 07:57:04 UTC
Where do I find: 1. Select Letter with Normal (0.75") Margins"

Note: If I change the locale of LibreOffice to English USA I do get 0,79 inch margin (with letter Page) But unsure if the 2.00 cm margin being inherited from my previous setting or if the 2.00 cm / 0,79 being hardcoded margin.
Comment 2 Eek! A Bug. Kill it! 2022-04-23 04:57:09 UTC
(In reply to Telesto from comment #1)
> Where do I find: 1. Select Letter with Normal (0.75") Margins"
> 
> Note: If I change the locale of LibreOffice to English USA I do get 0,79
> inch margin (with letter Page) But unsure if the 2.00 cm margin being
> inherited from my previous setting or if the 2.00 cm / 0,79 being hardcoded
> margin.


On the sidebar, 

1. Select the Page icon
2. under the Format section
3. first select the Size as Letter
4. then select a Margins setting of Normal (0.75")

The wrong margins do not seem to be inherited from previous settings but appear to be mis-coded -- and have been this way for the past couple years that I have used LO Writer.
Comment 3 Telesto 2022-04-23 07:32:52 UTC
If I set measurement to Inch, the sidebar page deck shows Normal 0,75 inch (in depend on paper format, with my Locale default is A4)

If I set measurement to Inch + Locale to English US, Papersize will be Letter. Deck shows Normal 0,75 Inch

Format -> Page Styles -> Page Tab shows it's actually 0,79 inch

Showing 0,75 Inch and actually being 0,79 is horrible :-(

I would have expected that every paper size using the default margins as normally used for the paper size in question 

Also found in
Version: 6.0.6.0.0+
Build ID: c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 Heiko Tietze 2022-04-25 15:16:26 UTC
Guess it's a duplicate of bug 135572.

*** This bug has been marked as a duplicate of bug 135572 ***