Bug 148765 - Calc Filter drop-down not opening Wayland
Summary: Calc Filter drop-down not opening Wayland
Status: VERIFIED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland KDE
  Show dependency treegraph
 
Reported: 2022-04-25 08:25 UTC by fil7racket
Modified: 2022-05-17 08:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fil7racket 2022-04-25 08:25:42 UTC
Description:
In Wayland, LibreOffice Calc filter list is not opening, if it somehow shows its only a few milliseconds.

To reproduce, open a new Spreadsheet using calc.
>paste any data 
>Click Data then AutoFilter
>Once filter is applied, click the drop-down list that displays the filter detail.
>then the issue will be seen.

It is happening when opening an excel file or a new one.


Steps to Reproduce:
1.open a new Spreadsheet using calc
2.enter any data
3.Click Data then AutoFilter
4.Once filter is applied, click the drop-down list that displays the filter detail.

Actual Results:
Filter list does not show after clicking drop-down list.
If it shows after click, its only brief like 100ms only

Expected Results:
filter list from drop-down should show like how filter is supposed to work


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

Operating System: KDE neon 5.24
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.13.0-40-generic (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-6300U CPU @ 2.40GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520

Version: 7.3.2.2 / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 fil7racket 2022-05-10 06:33:55 UTC
I have noticed that all drop-down options, like Background Color, Font Color, Column or Row drop-down list options are affected.

In X11, all are working fine. So I think only Wayland sessions are affected.
Comment 2 Michael Weghorn 2022-05-16 06:32:15 UTC
That sounds like bug 144585, which has been fixed in LibreOffice 7.3.3.
Please retest with that or newer versions.

*** This bug has been marked as a duplicate of bug 144585 ***
Comment 3 fil7racket 2022-05-17 08:08:45 UTC
Thanks Micheal, I have confirmed that LibreOffice 7.3.3 has fixed the issue as stated in this https://bugs.documentfoundation.org/show_bug.cgi?id=144585
Comment 4 Michael Weghorn 2022-05-17 08:33:16 UTC
(In reply to fil7racket from comment #3)
> Thanks Micheal, I have confirmed that LibreOffice 7.3.3 has fixed the issue
> as stated in this https://bugs.documentfoundation.org/show_bug.cgi?id=144585

Great, thanks for checking.