Bug 148813 - Option For Where Text Insertion Point Goes After Correcting a Word
Summary: Option For Where Text Insertion Point Goes After Correcting a Word
Status: RESOLVED DUPLICATE of bug 137972
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.6.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2022-04-27 04:39 UTC by vladspellbinder
Modified: 2022-05-25 08:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vladspellbinder 2022-04-27 04:39:37 UTC
Description:
Please add in an option to pick where the text insertion point position after after correcting a word via right-click -> select correction. Right now the cursor jumps to the FRONT of the word I just corrected while I would like for it to go BEHIND it as this is what I am accustomed to from other places and it throws me every single time in Writer.
I'm not sure if this is done in other Libraoffice programs as I tend to only use Writer and Calc.

Steps to Reproduce:
1. Open Writer
2. Misspell any word
3. Right click and select any correction option
4. Find that the text insertion point is now at the front of the corrected word instead of behind it.

Actual Results:
Get cursor in front of word corrected.

Expected Results:
Would like cursor after word corrected.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.6.2 (x64) / LibreOffice Community
Build ID: b0ec3a565991f7569a5a7f5d24fed7f52653d754
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 1 Dieter 2022-05-11 07:07:29 UTC
I confirm the behaviour with

Version: 7.3.3.2 (x64) / LibreOffice Community
Build ID: d1d0ea68f081ee2800a922cac8f79445e4603348
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Not sure, if an option is needed, but I think cursor right of the corrected word should be the default behaviour

cc: Design-Team for further input and decision

At least related to bug 102044
Comment 2 Heiko Tietze 2022-05-25 08:10:15 UTC

*** This bug has been marked as a duplicate of bug 137972 ***