Bug 148972 - PDF-Export does not accept '§' character (as password)
Summary: PDF-Export does not accept '§' character (as password)
Status: RESOLVED DUPLICATE of bug 50400
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
7.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export-File-Dialog
  Show dependency treegraph
 
Reported: 2022-05-06 23:44 UTC by Bernhard Spitzer
Modified: 2022-05-11 09:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Spitzer 2022-05-06 23:44:23 UTC
Description:
The PDF export dialog in LibreOffice does not accept a '§' character in the password dialog (open-password and rights password). The '§' is accepted in the confirm-box, but not in the first password box.
I tried it first with 7.2.x, then updated to the lastest 7.3.3.2 (x64) with the same result.

Steps to Reproduce:
1. open any document
2. file/export/export as PDF...
3. Security, enter § in the password box - no dot is printed.

Actual Results:
Passwords wich contain '§' show up shorter in the password input-box than in the confirm password box. Passwords dont mathc, no PDF created.

Expected Results:
§ in a password should be accepted


Reproducible: Always


User Profile Reset: No



Additional Info:
i tried it on different PCs with different LibreOffice versions.
Comment 1 BogdanB 2022-05-07 06:51:50 UTC
Confirm with
Version: 7.2.5.2 / LibreOffice Community
Build ID: 499f9727c189e6ef3471021d6132d4c694f357e5
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Calc: threaded
Comment 2 LeroyG 2022-05-09 19:08:29 UTC
Reproducible with
Version: 7.1.8.1 (x86) / LibreOffice Community
Build ID: e1f30c802c3269a1d052614453f260e49458c82c
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-MX (es_MX); UI: en-US
Calc: threaded
Comment 3 Timur 2022-05-11 09:33:04 UTC
Please search before reporting, this is a more general issue.

*** This bug has been marked as a duplicate of bug 50400 ***
Comment 4 Timur 2022-05-11 09:33:42 UTC
Please search before reporting and confirming..