Bug 149030 - UI: Make the animation effect list a drop down in the sidebar
Summary: UI: Make the animation effect list a drop down in the sidebar
Status: RESOLVED DUPLICATE of bug 145037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2022-05-11 08:05 UTC by Telesto
Modified: 2022-05-11 09:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2022-05-11 08:05:46 UTC
Description:
UI: Make the animation effect list a drop down in the sidebar

Steps to Reproduce:
1. Open Impress
2. Open the sidebar -> Animation Tab.. (Notice an empty effect list)
3. Insert a shape
4. Press Add Effect button
5. Notice the effect list being enabled

Actual Results:
A) The effect list is taking lots of space.. I find the list of existing animations for more interesting (and those can be pretty long.. 
B) The advantage of partly visible list instead of a drop down is unclear to me
C) There is always a risk you incidentally click on some entry in the effects list (and changing the effect un-intentionally)

Expected Results:
A simply ordinary drop down for selecting an effect..

The only problem might be if the categorizations.. but not sure if those labels are needed (still opinion those being trivial and distracting). A separator line would do enough, IMHO


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: cdf8e971d5d46df4bcab35a99c4254df9459213f
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (nl_NL); UI: en-GB
Calc: CL Jumbo
Comment 1 Heiko Tietze 2022-05-11 08:54:18 UTC
Lists are superior to dropdowns in case of large content. If you dislike the empty space, how about filling it even when disabled?
Comment 2 Telesto 2022-05-11 09:20:39 UTC
(In reply to Heiko Tietze from comment #1)
> Lists are superior to dropdowns in case of large content. If you dislike the
> empty space, how about filling it even when disabled?

The list being empty is more at the outer edges of my 'issue'.. Major point is more the large effect list using plenty of space in the sidebar, where the list of animations in document should have 'priority', IMHO

You currently can resize everything.. so you can grow the animation list.. But this goes at the expense of the effect list. At minimum the list will have only 3 items visible :-(. So list being superior for large content doesn't hold (especially with space restrictions) 
I'm anyhow not totally grasping why lists being better for large content? 
The font drop down contains a lot entry's depending on number of fonts installed on the system (nobody complains)

Go to Tools -> Customize -> Toolbars/ or context menu tab an expand target also a large list. Drop downs can work here too.. 

---
A drop down where you can even type to filter by name be faster compared to scrolling around a list (so mimicking the font box behaviour)

-- a couple of issues with my proposal
* There might be some 'issue' with automatic preview. Currently you can click on entry en the preview will play. If you have drop down box, the drop down box would collapse. But you could say keep mouse 4-5 seconds above some entry and it will play

* Another issue is that dropdown is mostly downwards orientated, but well there is not a lot of space. A large drop down would preferred compared to small one.
Which ends up reposition.. 'Add" and the list of effects first, and existing  animation in document below. I even think it's more natural workflow.

I tend to work top down.. You first need to add effect, before you have list of animations.. but well this depends on the workflow, adding animations vs editing pre-existing animations.

---
I obviously missed the whole design discussion of the the animation deck :-)
Comment 3 Heiko Tietze 2022-05-11 09:49:27 UTC
(In reply to Telesto from comment #2)
> You currently can resize everything.. 

The splitter was introduced for bug 145028.

The duplicate request in bug 145037 was rejected WF.

*** This bug has been marked as a duplicate of bug 145037 ***
Comment 4 Telesto 2022-05-11 09:59:10 UTC
(In reply to Heiko Tietze from comment #3)
> (In reply to Telesto from comment #2)
> > You currently can resize everything.. 
> 
> The splitter was introduced for bug 145028.
> 
> The duplicate request in bug 145037 was rejected WF.
> 
> *** This bug has been marked as a duplicate of bug 145037 ***

Sorry for bring this up again, it felt similar.. but didn't check my prior reports.. It's clear I still dislike the design :-)