Bug 149331 - Date Insert Menu Button Keyvoard Shortcut Inoperative - (with a scandinavian keyboard)
Summary: Date Insert Menu Button Keyvoard Shortcut Inoperative - (with a scandinavian ...
Status: RESOLVED DUPLICATE of bug 126888
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-27 09:30 UTC by Colin
Modified: 2022-06-01 18:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2022-05-27 09:30:03 UTC
Description:
The tool button for inserting the current date in the current cell is -according to the mouse hover tip- supposed to have a keyboard shortcut [Ctrl+;].
On a Scandinavian keyboard, the semicolon is a [shift] character so the key combination [Ctrl + Shft + ;] appears to be corrupting the shortcut and preventing it from inserting a date. For the record, the unshifted character is a comma.

I left the Severity as "normal" but it's probably "trivial" and the workaround is to use the menu button

It works fine in excel on the same Windows PC.

WRITER has a date picker with double click entry but no shortcut



Steps to Reproduce:
Select any cell and with a Scandinavian keyboard
Ctrl + Shft + ;


Actual Results:
Nothing

Expected Results:
Current date insertion


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 7.2.7.2 (x64) / LibreOffice Community
Build ID: 8d71d29d553c0f7dcbfa38fbfda25ee34cce99a2
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: sv-SE (en_GB); UI: en-GB
Calc: threaded
Comment 1 m.a.riosv 2022-06-01 17:44:24 UTC
I think the same issue as in https://bugs.documentfoundation.org/show_bug.cgi?id=126888, death keys doesn't work for shortcuts.

You can solve it reassigning a short without death keys in it.

Please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 126888 ***
Comment 2 Colin 2022-06-01 18:02:03 UTC
(In reply to m.a.riosv from comment #1)
> I think the same issue as in
> https://bugs.documentfoundation.org/show_bug.cgi?id=126888, death keys
> doesn't work for shortcuts.
> 
> You can solve it reassigning a short without death keys in it.
> 
> Please if you are not agree reopen it.

I don't disagree so it will remain RESOLVED and I'll change the shortcut key to unshifted characters that are available but - I also don't know what a death key may be :(.

I won't die if I don't know but it will worry me for the rest of my life ;)