Bug 149432 - Weird Hebrew font used by default on Windows 7
Summary: Weird Hebrew font used by default on Windows 7
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-Hebrew RTL-UI
  Show dependency treegraph
 
Reported: 2022-06-02 15:49 UTC by Shlomo belleli
Modified: 2022-08-05 12:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
images (88.79 KB, application/octet-stream)
2022-06-02 15:58 UTC, Shlomo belleli
Details
my setting (52.83 KB, image/png)
2022-06-17 07:46 UTC, Shlomo belleli
Details
yours defualt (52.65 KB, image/png)
2022-06-17 07:46 UTC, Shlomo belleli
Details
the stubborn font (29.43 KB, image/png)
2022-06-17 07:48 UTC, Shlomo belleli
Details
CTL_TEXT data (245.50 KB, image/png)
2022-06-17 14:43 UTC, Shlomo belleli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shlomo belleli 2022-06-02 15:49:21 UTC
Description:
I am using the writer to write a text document

Steps to Reproduce:
1. open a new text editor
2. open any dialog 
3. the text is written font that in Hebrew is used only in the Tora book and not in ordinary life

Actual Results:
the text in very hard to read and it is a mistake to use this font

Expected Results:
use standard font


Reproducible: Always


User Profile Reset: No



Additional Info:
I can send an image, but where to put the image on the bug report record?
Comment 1 Shlomo belleli 2022-06-02 15:58:47 UTC
Created attachment 180540 [details]
images
Comment 2 Shlomo belleli 2022-06-07 08:41:46 UTC
any response?
Comment 3 Shlomo belleli 2022-06-15 20:36:11 UTC
well?
is anyone is working on this bug report?
Comment 4 Dieter 2022-06-17 06:53:29 UTC
Shlomo, thank you for reporting this issue. You can easily customize the default font in Tools -> Customize -> Libreoffice Writer -> Basic Fonts (CTL)

Does this solve your problem? => NEEDINFO
Comment 5 Shlomo belleli 2022-06-17 07:45:12 UTC
No
The path to the basic font is Tools -> Options -> .....
I already tried it before opening this bug report
my dialog with basic fonts is attached and some other images
I even set it to LIbre... default (attached)
No one of these fonts in Hebrew is related to this special font (attached)
this font is rarely used in daily life
Comment 6 Shlomo belleli 2022-06-17 07:46:13 UTC
Created attachment 180807 [details]
my setting
Comment 7 Shlomo belleli 2022-06-17 07:46:55 UTC
Created attachment 180808 [details]
yours defualt
Comment 8 Shlomo belleli 2022-06-17 07:48:05 UTC
Created attachment 180809 [details]
the stubborn font
Comment 9 Ming Hua 2022-06-17 14:14:25 UTC
I don't speak Hebrew at all so take it for what it's worth, but here are my two cents regarding fonts in LibreOffice based on my experience with Chinese text:

David CLM is an open source font shipped with LibreOffice [1], so it's expected to exist on every system with LibreOffice installed.  On the other hand, Arial (your preferred choice, judging from your screenshot) is usually only available on Windows, and not on Linux or macOS unless the user explicitly installed it for compatibility reasons.

My understanding is that the default font in LibreOffice out of box (without changing any settings) depends on locale.  Search for "CTL_TEXT" in expert configurations (Tools > Options > LibreOffice > Advanced > Open Expert Configuration).  So you should also provide the detailed version information about your LibreOffice (Help > About LibreOffice > Version Information).

(In reply to Shlomo belleli from comment #8)
> Created attachment 180809 [details]
> the stubborn font
This doesn't look like David CLM, at least not on my system, either in LibreOffice or from the Windows font preview.

1. https://wiki.documentfoundation.org/Fonts
Comment 10 Shlomo belleli 2022-06-17 14:43:33 UTC
Created attachment 180812 [details]
CTL_TEXT data

my version
Version: 7.3.3.2 (x64) / LibreOffice Community
Build ID: d1d0ea68f081ee2800a922cac8f79445e4603348
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: he-IL (he_IL); UI: en-US
Calc: threaded
Comment 11 QA Administrators 2022-06-18 03:31:45 UTC Comment hidden (obsolete)
Comment 12 Dieter 2022-06-21 13:58:40 UTC
Eyal, could you help with this report? Can you confirm the problem?

cc: Eyal Rozenberg
Comment 13 Eyal Rozenberg 2022-06-21 20:40:33 UTC
(In reply to Dieter from comment #12)
> Eyal, could you help with this report? Can you confirm the problem?

No, I cannot confirm this. And - many people would have complained about this had it been a widespread occurrence. However, to be fair, I've only tried this in Windows 10. It is theoretically possible, though unlikely, that the bug manifests with Windows 7 ("6.1"). I'll ask someone with a Win 7 machine on the Hebrew channel to try it.

Shlomo, have you seen this only on a single computer, or on my than one system?
Comment 14 Eyal Rozenberg 2022-06-21 20:42:00 UTC
Also note that the font used in the user interface is not the font you choose in the "Basic Fonts" dialog. That dialog is for the fonts used in the document, not in the UI.
Comment 15 Eyal Rozenberg 2022-07-29 19:13:14 UTC
Waiting for Shlomo's response.
Comment 16 Shlomo belleli 2022-08-05 12:14:31 UTC
I tested this on Win10 on several computers - and no problem
Only on Win7 one computer, we don't have others with that ops sys - the error exists
Shlomo
Comment 17 Eyal Rozenberg 2022-08-05 12:35:04 UTC
Now we just need someone with a Windows 7 machine...