Bug 149546 - CRASH: importing document
Summary: CRASH: importing document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.5.0 target:7.4.0.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2022-06-13 09:27 UTC by Xisco Faulí
Modified: 2022-07-13 07:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (60.03 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2022-06-13 09:27 UTC, Xisco Faulí
Details
Bugdoc without macro (22.72 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2022-06-13 09:57 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2022-06-13 09:27:30 UTC
Created attachment 180720 [details]
sample file

Steps to reproduce:
1. Open attached document

-> it crashes at import time. Repeat a few times in case it doesn't crash. it happens every other time

Reproduced in

Version: 7.4.0.0.alpha1+ / LibreOffice Community
Build ID: d4123356c61db269651e950a0a2cc93e6d801c90
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: x11
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2022-06-13 09:28:13 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2951cbdf3a6e2b62461665546b47e1d253fcb834

author	Attila Bakos (NISZ) <bakos.attilakaroly@nisz.hu>	2021-11-10 14:10:11 +0100
committer	László Németh <nemeth@numbertext.org>	2022-01-03 14:28:15 +0100
commit 2951cbdf3a6e2b62461665546b47e1d253fcb834 (patch)
tree d09834b7f1e68e7b3664ed03c5d2ed3c73de552d
parent cce57fd94e9335c5dd5f3725a5fe54f5d3929e8d (diff)
tdf#143574 OOXML export/import of textboxes in group shapes

Bisected with: bibisect-linux64-7.4

Adding Cc: to Attila Bakos
Comment 2 Attila Bakos (NISZ) 2022-06-13 09:39:25 UTC Comment hidden (obsolete)
Comment 3 Attila Bakos (NISZ) 2022-06-13 09:57:02 UTC
Created attachment 180721 [details]
Bugdoc without macro

Reproduced from blank, steps:
1) In word, insert a shape to footer
2) Insert a textbox to the footer too.
3) Group.
4) Set Anchor Aschar.
5) Save and open in Writer
->Crash

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: cad76135ef6a72b6b7aa7d9dfc81ff77d01fefbe
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

(Reconstructed according to the original xml.)
Fixing in progress.
Comment 4 Attila Bakos (NISZ) 2022-06-20 15:41:21 UTC
patch will be here: https://gerrit.libreoffice.org/c/core/+/136192
Comment 5 Xisco Faulí 2022-06-21 08:50:43 UTC
(In reply to Attila Bakos (NISZ) from comment #4)
> patch will be here: https://gerrit.libreoffice.org/c/core/+/136192

@Caolán, I'm adding you here since this was also found by the crashtesting instance, so you are aware
Comment 6 Commit Notification 2022-07-11 12:10:14 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1d3d2a995239c3c71432006cb795324c56a0412a

tdf#148687 tdf#149173 tdf#149546 sw: fix crash with textboxes

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 NISZ LibreOffice Team 2022-07-13 06:50:32 UTC
Verified in:
Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a4ab155ae15e9e6d4deb157634f8b86c87fcbde4
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 8 Commit Notification 2022-07-13 07:26:08 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/44eef5f494825a26594ba3d50ef1f3211ae73b9b

tdf#148687 tdf#149173 tdf#149546 sw: fix crash with textboxes

It will be available in 7.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.