Bug 149679 - CRASH: importing document in ScQueryEvaluator::compareByString<0>
Summary: CRASH: importing document in ScQueryEvaluator::compareByString<0>
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.4.0.0 beta1+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.4.0.0.beta2 tar...
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2022-06-22 17:25 UTC by Xisco Faulí
Modified: 2022-06-26 00:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["ScQueryEvaluator::compareByString<0>(ScQueryEntry const &,ScQueryEntry::Item const &,svl::SharedString const *,rtl::OUString const *)"]
Regression By: Luboš Luňák


Attachments
sample file (9.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-06-22 17:25 UTC, Xisco Faulí
Details
bt with debug symbols (24.24 KB, text/plain)
2022-06-22 18:38 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2022-06-22 17:25:21 UTC
Created attachment 180913 [details]
sample file

Steps to reproduce:
1. Open attached document

-> It crashes

Reproduced in

Version: 7.4.0.0.beta1+ / LibreOffice Community
Build ID: 6ab56a4fc946f6294513f23a3ea47aa0aa154b7d
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: tr-TR (es_ES.UTF-8); UI: en-US
Calc: threaded

but not in

Version: 6.3.0.0.alpha1+
Build ID: c98b1f1cd43b3e109bcaf6324ef2d1f449b34099
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3; 
Locale: es-ES (es_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2022-06-22 17:26:51 UTC
Regression introduced by:

author	Luboš Luňák <l.lunak@collabora.com>	2021-11-16 01:30:24 +0100
committer	Luboš Luňák <l.lunak@collabora.com>	2021-11-17 10:10:58 +0100
commit 8dec2a98ce29251936cd45ebf864a89ff767ee50 (patch)
tree 5b336bda4ba803f2859bc0bdc0a57e89ab6213d8
parent fcad2503ede92b515076f9bb3162855dcc2c575d (diff)
revert "vlookup - optimize SC_EQUAL and NOT_EQUAL." (tdf#139612)

Bisected with: bibisect-linux64-7.3

Adding Cc: to Luboš Luňák
Comment 2 Xisco Faulí 2022-06-22 17:27:25 UTC
@Caolán, I'm also adding you here since this issue was also found by the crashtesting instance
Comment 3 Julien Nabet 2022-06-22 18:38:36 UTC
Created attachment 180917 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got an assertion.
Comment 4 Commit Notification 2022-06-24 06:39:09 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9e170a35eebbe86e6137510bc8ea34e5a45dbd8d

handle nullptr SharedString in ScQueryEvaluator (tdf#149679)

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2022-06-24 09:12:34 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/ec287f4f884c94ca5490d6d5139df44fc32cd03c

handle nullptr SharedString in ScQueryEvaluator (tdf#149679)

It will be available in 7.4.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Julien Nabet 2022-06-24 10:49:40 UTC
On pc Debian x86-64 with master sources updated today (with Luboš' patch), I confirm I don't reproduce the crash anymore.

Thank you Luboš!
Comment 7 Commit Notification 2022-06-24 14:50:18 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/995cb63408f28753b868845641d584f1fac005aa

tdf#149679: sc_subsequent_filters_test: Add unittest

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-06-26 00:20:58 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/4e2f3912440e555f62ea9f5b8182fd6c07560001

handle nullptr SharedString in ScQueryEvaluator (tdf#149679)

It will be available in 7.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.