Bug 149688 - Under Windows 10 with high contrast display on black background, the Writer's menu items disappear: written white on white
Summary: Under Windows 10 with high contrast display on black background, the Writer's...
Status: RESOLVED DUPLICATE of bug 98067
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.2.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: High-Contrast
  Show dependency treegraph
 
Reported: 2022-06-23 05:54 UTC by Bernard Drapeau
Modified: 2022-09-29 13:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Drapeau 2022-06-23 05:54:57 UTC
Description:
Writer ignores color selection from the high contrast (on Windows: Start> Setting> Ease of Access> Hi Contrast> High Contrast ON) and displays the text area with a White background with black letters where the background should be Black with white letters. 

The top menu items are written in white letters on a white background. They are unreadable. The ALT key enables the menu item and it will be correctly written with white letters on a black background. The frame of the window stays white, where it should be black. 

Steps to Reproduce:
1. Activate high contrast on the Windows platform (Start> Settings> Ease of Access> High Contrast> Hi Contrast ON)
2. Start LibreOffice, Writer


Actual Results:
Look at the menu and the frame of Writer. It is written white on white.

The application background should be all Black with white letters, activators and menu.
The center of the page should be black, not white.
The elevators should be White on a black background.

Expected Results:
Like the rest of the applications running on Windows with High Contrast: 
The text, the Icons, the elevators should be White and the Background should be black.


Reproducible: Always


User Profile Reset: No



Additional Info:
I don't have access to the Windows box. 
I configured my mother's machine remotely and I am disconnected from her box.
It is running Windows 10 with LibreOffice 7.3
My mother has problems with her eyesight.
I thought of using the same configuration as a colleague who has 25% eyesight. 
Bigger letters and higher contrast.

LibreOffice runs perfectly but the interface is affected, it is unreadable.
It is white on white.

By pressing the Alt key we can activate the menu and then press down arrow. 
It is then normal behavior: white letters on black background.
Comment 1 V Stuart Foote 2022-06-23 19:34:51 UTC
This works sufficiently well. IMHO => NAB but room to improve. Seems a dupe of bug 93032, but that probably needs revisit given work on bug 118320

Please retest doing these steps.

1. Please set LibreOffice to LibreOffice Dark color mode and enable the Windows theme experimental support:

Tools -> Options -> Application Colors, and select the 'LibreOffice Dark' Color Scheme

2. And also, enable Experimental features:

Tools -> Options -> Advanced 'Enable experimental features (may be unstable)'.

Those two settings will make the HC functional to a point--LibreOffice can not read Microsoft UWP provided color themes. But does respond to HC mode.

Setting the os/DE, i.e. Windows Display Manager (WDM) into HighContrast is picked up by LibreOffice; unfortunately the subset of the HighContrast DE colors passed into LibreOffice is insufficient for a full mapping. 

You'll know you are in HC assistive technology mode bcz the icon theme will change to 'Sifr'

There are four Windows 10 pre-defined High Contrast modes:

High Contrast #1
High Contrast #2
High Contrast Black
High Contrast White

both High Contrast #2, and High Contrast White are fully readable with LibreOffice set to Dark mode and experimental features enabled.

The third party Grey Eve theme [1] is also pretty functional (non-UWP, it still signals it is a HC theme but provides a more complete color mapping).

=-ref-=
[1] https://github.com/nitschis/GreyEveTheme
Comment 2 Timur 2022-09-29 13:08:58 UTC
This looks like a duplicate of another menu bug.

*** This bug has been marked as a duplicate of bug 98067 ***