Bug 149711 - DOCX Track Changes: Writer does not import change tracking of the paragraph mark of a moved list item (see Comment 2)
Summary: DOCX Track Changes: Writer does not import change tracking of the paragraph m...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.5.0.0 alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.4.0.2
Keywords:
Depends on:
Blocks: Track-Changes-Lists
  Show dependency treegraph
 
Reported: 2022-06-24 07:35 UTC by NISZ LibreOffice Team
Modified: 2022-07-26 08:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (13.30 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2022-07-07 15:37 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2022-06-24 07:35:48 UTC
Description:
Writer does not show the change in serial numbers in numbered lists when an item is inserted.

Steps to Reproduce:
1. Create a numbered list in LibreOffice Writer.
2. Record Track Changes. (Ctrl - Shift - E)
3. Create a new element in the list.


Actual Results:
Writer does not show that the last item was the 3. previously.

Expected Results:
Show that the last item was the third list item previously.


Reproducible: Always


User Profile Reset: No



Additional Info:
Follow-up to Bug 115524.

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: cb22629eb251de97084ab11f80cb54687483996f
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 Eike Rathke 2022-06-25 07:57:54 UTC

*** This bug has been marked as a duplicate of bug 149709 ***
Comment 2 László Németh 2022-07-07 15:35:47 UTC
moveTo paragraph mark is imported as an old paragraph with new content, resulting that e.g. rejecting a moved list item leaves an empty list item instead of removing the moved list item completely.
Comment 3 László Németh 2022-07-07 15:37:19 UTC
Created attachment 181157 [details]
test file
Comment 4 Commit Notification 2022-07-08 07:32:51 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/11071d95f4f3cbe578c3393729c42b7cce011b45

tdf#149711 sw_redlinenum DOCX: import moveTo paragraph mark

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2022-07-08 10:08:14 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/626be09128b9bd360ab05aa6eea02c826ff6ec77

tdf#149711 sw_redlinenum DOCX: import moveTo paragraph mark

It will be available in 7.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 NISZ LibreOffice Team 2022-07-26 08:24:55 UTC
Verified in:
Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 5df1bb4b1b222be00d25097660c4ee33542896ea
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL