Bug 149915 - It is not possible to delete an embedded database
Summary: It is not possible to delete an embedded database
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.5.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.5.0 target:7.4.1 target:7.3.6
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-08 11:47 UTC by Gülşah Köse
Modified: 2022-10-19 11:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
à.odt (don't change the file name) (11.29 KB, application/vnd.oasis.opendocument.text)
2022-07-08 11:50 UTC, Gülşah Köse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2022-07-08 11:47:36 UTC
Description:
-

Steps to Reproduce:
1. Open the à.odt (keep the file name unchanged)
2. Tool->Options->LibreOffice Base->Databases
3. Delete the "test-publi" click OK.
4. Save the file and close.
5. Open the à.odt again.
6. Check Tool->Options->LibreOffice Base->Databases 

Actual Results:
"test-publi" entry is there.

Expected Results:
We shouldn't see that databse again.


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Gülşah Köse 2022-07-08 11:50:26 UTC
Created attachment 181173 [details]
à.odt (don't change the file name)
Comment 2 m.a.riosv 2022-07-09 07:33:02 UTC
I can be sure it is a bug, since @vmiklos https://archive.fosdem.org/2016/schedule/event/libreoffice_mail_merging/, I think the connection is kept in the odt file, and it is temporarily created while the file it's opened. But it is not saved in the profile. You can see every time the file is opened/closed, the connection appear/disappear.
Comment 3 m.a.riosv 2022-07-09 07:33:25 UTC
(In reply to m.a.riosv from comment #2)
> I can be sure it is a bug, since @vmiklos
I can't..
Comment 4 Commit Notification 2022-07-20 17:21:44 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9790585a62cb55e0e0024819596592193a6de269

tdf#149915 Proper creation of vnd.sun.star.pkg:// URL

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2022-07-30 08:53:51 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/7369cef79ba7580bc30e48cec4d1a6fdcc8444f6

tdf#149915 Proper creation of vnd.sun.star.pkg:// URL

It will be available in 7.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2022-07-30 08:54:02 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/ccd7b9435f41d4be750555fe23ff12a73fb5e345

tdf#149915 Proper creation of vnd.sun.star.pkg:// URL

It will be available in 7.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.