Bug 149957 - Screen Size Does Not Carry to Next Session with LO 7.4
Summary: Screen Size Does Not Carry to Next Session with LO 7.4
Status: RESOLVED DUPLICATE of bug 150236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2022-07-11 23:38 UTC by Mark
Modified: 2022-08-19 05:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2022-07-11 23:38:59 UTC
Description:
After installing 7.4.0.1 and launching LibreOffice, the main home screen only occupies about 66% of the screen. Resizing the app, closing it, and relaunching it does not preserve the resized screen size. This behavior consistently applies to launching the home screen, existing documents, and individual apps within LibreOffice.

Steps to Reproduce:
1.Install 7.4.0.1
2.Launch Office
3.Resize screen
4.Close Office
5.Relaunch Office.

Actual Results:
Resized screen is not "saved"

Expected Results:
Screen should be the same size as when last used.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: StartModule
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 Timur 2022-07-12 09:20:36 UTC
ooSetupFactoryWindowAttributes exists for each document type and also for Start center. 

So if Start center is open, without document, and resized, or should be remembered. But if Start center is open and then some document open, that module  resized window size will not remembered on reopen. But if module is opened directly, like via double click on a file, then resized window size for that module should  be remembered. 
And all that would not be a bug. 

Please confirm if you have the same behavior. Or write in detail your steps.
Comment 2 Mark 2022-07-12 21:10:19 UTC
When I open Start Center, it displays recent documents in a window that occupies about 66% of the screen. (This is on a laptop with an external monitor attached via HDMI. The Start Center window also only occupies 66% of the laptop monitor.

When I maximize the Start Center window, close LibreOffice and relaunch it, the Start Center window is not maximized.

If I double click on a document from File Explorer and resize/maximize the document and then close it, the document window size is not remembered.
Comment 3 QA Administrators 2022-07-13 03:31:12 UTC Comment hidden (obsolete)
Comment 4 Timur 2022-07-13 08:18:05 UTC
(In reply to Mark from comment #2)
> When I maximize the Start Center window, close LibreOffice and relaunch it,
> the Start Center window is not maximized.

If you do it without opening document, that's strange, I don't reproduce.
Comment 5 Timur 2022-07-15 11:24:39 UTC
Please try to LO User Profile Reset which is folder rename. 
And also with an external monitor disconnected.
Comment 6 Mark 2022-07-15 23:53:27 UTC
Disconnected external monitor and reset user profile. No change: the screen still does not restore.

I went to uninstall 7.4.0.1 and notices that the beta1 version was still listed in the app list. I uninstalled it. That did not correct the issue. I uninstalled 7.4.0.1 and reinstalled it. That did not correct the issue.

I uninstalled 7.4.0.1 and then installed 7.3.5.1. This corrected the issue.
Comment 7 QA Administrators 2022-07-16 03:54:32 UTC Comment hidden (obsolete)
Comment 8 Timur 2022-07-18 09:03:07 UTC
*** Bug 150003 has been marked as a duplicate of this bug. ***
Comment 9 Timur 2022-07-18 09:03:50 UTC
New by duplicate.
Comment 10 John 2022-08-14 11:22:44 UTC
Window position and size is still not being remembered in 7.4.0.3. Tested in Windows Sandbox and so on a completely clean install.

I think that this is more than low / minor. It is a real pain having to resize and move the LO window each time an app is opened and I won't be moving to 7.4.x until it has been fixed.
Comment 11 Timur 2022-08-18 19:08:02 UTC
*** Bug 150478 has been marked as a duplicate of this bug. ***
Comment 12 Timur 2022-08-18 19:14:06 UTC
Seems that multiple users have this, although it seems not generally reproducible. 
To be High, it would need a bibisect.
Comment 13 Kityn 2022-08-18 22:17:09 UTC
(In reply to Timur from comment #12)
> Seems that multiple users have this, although it seems not generally
> reproducible. 
> To be High, it would need a bibisect.
Bisected by Xisco Faulí: https://bugs.documentfoundation.org/show_bug.cgi?id=150236#c27
Comment 14 V Stuart Foote 2022-08-19 05:23:09 UTC

*** This bug has been marked as a duplicate of bug 150236 ***