Bug 150003 - LO 7.4.0.1 does not remember window position
Summary: LO 7.4.0.1 does not remember window position
Status: RESOLVED DUPLICATE of bug 150236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.4.0.0 beta1+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-15 09:04 UTC by John
Modified: 2022-08-19 05:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John 2022-07-15 09:04:36 UTC
Just tried 7.4.0.1 on Win11 Pro. In previous versions up to 7.3.5.1 LO (both writer and calc) would remember the position of the last used window. On restarting, the window would open in the last used position. In 7.4.0.1 this no longer happens. On first run after installing over 7.3.x the window opens in the correct last used position but thereafter the window opens in what appears to be a default position and is not remembered. Instead is has to be reset each time which is a bit of a pain.
Comment 1 Timur 2022-07-15 11:26:39 UTC
Please try with LO User Profile Reset which is folder rename. 
Then write exactly what you do. Just open Start center, without documents, change position and size and close and reopen. 
Position exists for each document type and also for Start center separately. 
So if Start center is open, without document, and resized, or should be remembered. But if Start center is open and then some document open, that module  resized window size will not remembered on reopen. But if module is opened directly, like via double click on a file, then resized window size for that module should  be remembered.
Comment 2 John 2022-07-15 17:25:01 UTC
I uninstalled LO completely, removed C:\Users\xxx\AppData\Roaming\LibreOffice and installed LO 7.4.0.1.

Opened start centre, resized it and closed it. No documents were opened. On reopening start centre it was in the default position, not where I had set it.

Similarly on opening writer without creating a document. Resized the window, closed writer, reopened writer - window in default position, not where I had left it. Then created and saved a document, closed writer and reopened writer by double clicking the document - again, the window opened in the default position, not where it had been set.

I had put 7.4 back to retest as asked but in fact had uninstalled it this morning and reinstalled 7.3 because of this issue. On reinstalling 7.3, normal behaviour returned. I cannot see that this has anything to do with the user profile.
Comment 3 QA Administrators 2022-07-16 03:54:38 UTC Comment hidden (obsolete)
Comment 4 Timur 2022-07-18 09:03:07 UTC
Seems there's a similar report so I'll mark duplicate.

*** This bug has been marked as a duplicate of bug 149957 ***
Comment 5 V Stuart Foote 2022-08-19 05:25:52 UTC

*** This bug has been marked as a duplicate of bug 150236 ***