Bug 150212 - Window size and position not remembered
Summary: Window size and position not remembered
Status: RESOLVED DUPLICATE of bug 150236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 beta1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-01 05:39 UTC by Kim
Modified: 2022-08-19 05:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kim 2022-08-01 05:39:22 UTC
Description:
Libreoffice 7.4.0.1 and 7.4.0.2 do not remember the size and position of files saved in those versions, but open the file in a small window centred on the screen.

Steps to Reproduce:
1. In LO 7.4.0.1 or 7.4.0.2, open a Writer file created in an earlier version of LO. It opens where it did last time.
2. Modify and save the file and quit LO.
3. Open the file again. 

Actual Results:
The file does not open in a window the size and position it was under the previous version, but in a small window centred on the screen (the main screen if you have more than one).

Expected Results:
The previous size and position of the file window should be remembered between sessions.


Reproducible: Always


User Profile Reset: No



Additional Info:
I have only tried Writer files and do not know about other LO components.
Comment 1 Dieter 2022-08-15 16:02:56 UTC
I can't confirm it with

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: df3b7599f5ad92337a495224f53a1299cc82e97e
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Additional informations:
1. Size of the window is not document specific. LO opens with the last used size
2. Please make sure, that document contains author's forename and surename, because without that, focus after opening is not at last position
Comment 2 Kim 2022-08-16 01:12:51 UTC
The bug was still present in:
Version: 7.4.0.3 (x64) / LibreOffice Community
Build ID: f85e47c08ddd19c015c0114a68350214f7066f5a
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: en-AU (en_AU); UI: en-GB
Calc: threaded

I did not imply that size and position were document-specific, only that size and position were *not* remembered from previous time.

User forename and surname fields are populated in user data.
Comment 3 Dieter 2022-08-16 07:04:59 UTC
KIm, to be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile (https://wiki.documentfoundation.org/UserProfile) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present.
Comment 4 Olivier R. 2022-08-18 15:06:33 UTC
Bug confirmed.

Version: 7.4.0.3 (x64) / LibreOffice Community
Build ID: f85e47c08ddd19c015c0114a68350214f7066f5a
CPU threads: 16; OS: Windows 10.0 Build 22000; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); UI: fr-FR
Calc: CL
Comment 5 V Stuart Foote 2022-08-19 05:39:44 UTC

*** This bug has been marked as a duplicate of bug 150236 ***