Bug 150221 - Only one character pasted when copying RTL text from Writer to textbox in Draw
Summary: Only one character pasted when copying RTL text from Writer to textbox in Draw
Status: RESOLVED DUPLICATE of bug 150151
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.5.0.0 alpha0+ Master
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2022-08-01 18:20 UTC by Kamil Landa
Modified: 2022-08-12 11:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By: Luboš Luňák


Attachments
example of bad copy arabic text from Writer to TextBox in Drawing (56.30 KB, application/vnd.oasis.opendocument.text)
2022-08-01 18:20 UTC, Kamil Landa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kamil Landa 2022-08-01 18:20:54 UTC
Created attachment 181534 [details]
example of bad copy arabic text from Writer to TextBox in Drawing

Draw: Bad Paste copied arabic text from Writer to the Text Box in Drawing


1) Write some arabic text in Writer, select it and copy it Ctrl+C
2) Open new Drawing and insert Text Box (F2)
3) Paste Ctrl+V to the Text Box in Drawing - it Pastes only one arabic letter


BUG:
Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 41f02927b6d8470c298c8a2f407c98420a5ebe24
CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-US
Calc: CL

Version: 7.4.0.1 (x64) / LibreOffice Community
Build ID: 43e5fcfbbadd18fccee5a6f42ddd533e40151bcf
CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: cs-CZ
Calc: CL


OK in:
Version: 7.3.5.1 (x64) / LibreOffice Community
Build ID: d56c1c78db15939340c3db8ee3b6667832313d23
CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: cs-CZ
Calc: CL
Comment 1 raal 2022-08-02 15:13:13 UTC
confirm with Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 3ccbfaaf95005a34ca64ad250463ef5ce8842f43
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 2 raal 2022-08-02 15:23:48 UTC
This seems to have begun at the below commit.
Adding Cc: to Luboš Luňák; Could you possibly take a look at this one?
Thanks
 81300730a040c83a05df3c9587bd76ff57d935a3 is the first bad commit
commit 81300730a040c83a05df3c9587bd76ff57d935a3
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Mar 1 21:45:36 2022 +0100

    source sha:09558e2f45e27d572fd261562c884c2d2cc896a7

https://git.libreoffice.org/core/+/09558e2f45e27d572fd261562c884c2d2cc896a7
Comment 3 Eyal Rozenberg 2022-08-05 13:22:40 UTC
Also seeing this with Hebrew test:

1. Open the attached document
2. Navigate to the end of the Arabic text line
3. Press Enter
4. Type in "שלום"
5. Start Draw
6. Insert a Text Box
7. Paste

Only the first ש gets pasted.

More notes:

* Removing the Arabic diacritics doesn't help.
* Pasting to some plain text editor, then copying, then pasting into the textbox in draw does not trigger this bug.
Comment 4 Kamil Landa 2022-08-05 17:15:18 UTC
Functional is: Edit/ Paste Special/ Paste Unformatted Text
Comment 5 Luboš Luňák 2022-08-12 11:11:30 UTC

*** This bug has been marked as a duplicate of bug 150151 ***