Bug 150331 - EDITING: AutoCorrect without "Show as tip" always fills in rest of word regardless of next key stroke
Summary: EDITING: AutoCorrect without "Show as tip" always fills in rest of word regar...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 beta1+
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.4.1
Keywords: bibisected, bisected, regression
: 150455 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-08-10 08:38 UTC by Julian Gilbey
Modified: 2022-08-19 09:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By: Szymon Kłos


Attachments
Bibisect log (4.60 KB, text/plain)
2022-08-17 13:07 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Gilbey 2022-08-10 08:38:55 UTC
This is with version 7.4.0.2 (prerelease version).

I open a new Writer document (English language).  My AutoCorrect options under Word Completion have:
* Enable word completion (ticked)
*   Append space (not ticked)
*   Show as tip (not ticked)
* Accept with: (return/enter key)

I then type (without the quote marks): "Sun" and AutoCorrect offers the option "Sunday", showing me the letters "day" with a dotted underline and pale blue background.  So far so good.  But whatever I type next, these three characters are kept.  So if I try to type "Sunny", I end up with "Sundayny"; "Sun" followed by backspace ends up with "Sunda", and "Sun" followed by enter/return ends up with "Sundayday".

This behaviour occurs on both Debian GNU/Linux (version 7.4.0~rc2-3) and MacOS (version 7.4.0.2).

I've marked it as "major" because it causes Writer to be really annoying and hard to use, and is likely to lead to errors.
Comment 1 BogdanB 2022-08-11 04:44:37 UTC
I confirm it is working strange

"Sundayday Sunday sundayd"

Version: 7.4.0.2 / LibreOffice Community
Build ID: 1512ce97d7ed39dce3121f7e15651fd8895f950e
CPU threads: 16; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 2 Timur 2022-08-17 12:27:47 UTC
*** Bug 150455 has been marked as a duplicate of this bug. ***
Comment 3 Telesto 2022-08-17 13:07:08 UTC
Created attachment 181829 [details]
Bibisect log

Bisected to

author	Szymon Kłos <szymon.klos@collabora.com>	2021-12-17 13:19:28 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2022-01-23 19:53:58 +0100
commit 218acb48df79101392c2cc3a030ddb5dcee878c7 (patch)
tree 2026a703f5629ee075843eb0692c5171e956cada
parent 1cc2690fe2f87e8acce4e9b4e0cb533fda26e295 (diff)
tdf#146728 lok: IME: preset formatting in the new paragraph
When we wrote something using Heading or Title style and
then moved to the next paragraph by pressing enter
we should get "Text Body" style in the new line.

Do not copy style. Use NOHINTEXPAND when inserting initially
so we can use EMPTYEXPAND later - at the end of composing -
and use correct styling.

followup for:
lok: IME: directly copy formatting for inserted text d8dbd123bfa7f39489ceb15ac83142635531fd43

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d8dbd123bfa7f39489ceb15ac83142635531fd43
Comment 4 Xisco Faulí 2022-08-18 12:10:58 UTC
my take on it: https://gerrit.libreoffice.org/c/core/+/138485
Comment 5 Commit Notification 2022-08-19 08:01:53 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aed6183b12f496e1dcb7429a88da9e521ba622a3

tdf#150331: update index only when text is inserted

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2022-08-19 09:15:31 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3d045ef37475a993738855abde82fca90626f3b2

tdf#150331: sw: Add UItest

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-08-19 09:34:10 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/ecc1568567d9e879ae861eaeb6c12a9a6c06a8d3

tdf#150331: update index only when text is inserted

It will be available in 7.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.