Bug 150395 - Wrong Kashida inserted in an Arabic text in a paragraph started with English text
Summary: Wrong Kashida inserted in an Arabic text in a paragraph started with English ...
Status: RESOLVED DUPLICATE of bug 103492
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-13 10:36 UTC by Hossein
Modified: 2022-08-13 15:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hossein 2022-08-13 10:36:43 UTC
Description:
In a paragraph that contains Arabic text, if English (or LTR characters) are inserted in the start of the paragraph, wrong Kashida is inserted in the Arabic text.

Steps to Reproduce:
1. Open the attachment 149834 [details]


Actual Results:
Wrong Kashida inserted in an Arabic text, as unwanted horizontal lines

Expected Results:
Kashida should be placed in the correct position between the Arabic characters


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.1
Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 خالد حسني 2022-08-13 14:53:16 UTC
Same issue as bug 103492

*** This bug has been marked as a duplicate of bug 103492 ***
Comment 2 خالد حسني 2022-08-13 15:11:47 UTC
(In reply to Khaled Hosny from comment #1)
> Same issue as bug 103492
> 
> *** This bug has been marked as a duplicate of bug 103492 ***

(in case any one is wondering, turns out text boxes in Writer use the same text engine (editengine) that the rest of LO use, not Writers its own separate text engine).