Bug 150478 - LibreOffice always starts in unmaximized window
Summary: LibreOffice always starts in unmaximized window
Status: RESOLVED DUPLICATE of bug 150236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-18 15:58 UTC by Yan Fiz
Modified: 2022-08-19 05:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Fiz 2022-08-18 15:58:28 UTC
Description:
LibreOffice doesn't remember last used maximized window status.

Steps to Reproduce:
1. Run LibreOffice
2. Maximize window
3. After re-run it, check if it is still maximized

Actual Results:
If you close LibreOffice as maximized window, it will be opened as unmaximized next time.

Expected Results:
If you close LibreOffice as maximized window, it should be opened as maximized next time, too.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 7.4.0.3 (x64) / LibreOffice Community
Build ID: f85e47c08ddd19c015c0114a68350214f7066f5a
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: tr-TR (en_US); UI: en-US
Calc: CL
Comment 1 blank15927 2022-08-18 16:35:38 UTC
(In reply to Yan Fiz from comment #0)
> Description:
> LibreOffice doesn't remember last used maximized window status.
> 
> Steps to Reproduce:
> 1. Run LibreOffice
> 2. Maximize window
> 3. After re-run it, check if it is still maximized
> 
> Actual Results:
> If you close LibreOffice as maximized window, it will be opened as
> unmaximized next time.
> 
> Expected Results:
> If you close LibreOffice as maximized window, it should be opened as
> maximized next time, too.
> 
> 
> Reproducible: Always
> 
> 
> User Profile Reset: Yes
> 
> 
> OpenGL enabled: Yes
> 
> Additional Info:
> Version: 7.4.0.3 (x64) / LibreOffice Community
> Build ID: f85e47c08ddd19c015c0114a68350214f7066f5a
> CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL:
> win
> Locale: tr-TR (en_US); UI: en-US
> Calc: CL

- Windows 10

I see that too. LibreOffice 7.4.0.3 does not retain the dimensions + positions of the last opening of the software. If I maximized, it always reopen unmaximized.
Comment 2 Timur 2022-08-18 19:08:02 UTC
Seems duplicate.

*** This bug has been marked as a duplicate of bug 149957 ***
Comment 3 V Stuart Foote 2022-08-19 05:23:26 UTC

*** This bug has been marked as a duplicate of bug 150236 ***