Bug 150485 - Writer opens on main display after being shut down from the secondary monitor
Summary: Writer opens on main display after being shut down from the secondary monitor
Status: RESOLVED DUPLICATE of bug 150236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-19 01:19 UTC by alan.german
Modified: 2022-08-19 06:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alan.german 2022-08-19 01:19:30 UTC
Description:
On an updated installation to Version 7.4.0.3, on my dual-monitor setup, Writer is shut down from the secondary monitor where it is set to display at full height (portrait mode).  When re-opened, Writer loads on the primary monitor, in a smaller, landscape-mode window in the middle of the main display.  Earlier versions have reloaded the LibreOffice Window on the same monitor and at the same size as used previously.

Steps to Reproduce:
1.Open Writer
2.Move window to secondary monitor
3.Resize window to full height of screen
4.Create and save a file
5.Close Writer
6.Open Writer

Actual Results:
Writer opens in small, landscape window on main monitor

Expected Results:
Writer should have opened in portrait mode on the secondary monitor


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Note that this only occurs with Version 7.4.0.3.  This version number is not included in the drop-down meu for Versions (earliest affected) and "Submit Bug Report) will not accept the "unspecified" option in the menu.
Comment 1 V Stuart Foote 2022-08-19 05:23:54 UTC

*** This bug has been marked as a duplicate of bug 150236 ***
Comment 2 V Stuart Foote 2022-08-19 06:11:17 UTC
confirmed with 7.4.0.2 on Windows on a dual headed system.

1. Start Center draged to right monitor. 
2. Writer launched into frame of Start Center.
3. Writer document and frame forced close with 'X'
4. launch Writer from swriter.exe

position onto left monitor


Does not orccur if steps rerun with 7.3.4.2

Does not occur if steps rerun with recent build of master against 7.5.0

so, another manifestation of issues bisected in bug 150236