Bug 150620 - Paste Special - Format Only doesn't stick
Summary: Paste Special - Format Only doesn't stick
Status: RESOLVED DUPLICATE of bug 69750
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.5.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2022-08-26 11:04 UTC by ayla.alhollandiyah
Modified: 2022-09-01 07:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ayla.alhollandiyah 2022-08-26 11:04:30 UTC
Description:
I recently updated from Libre 7.2.7 to 7.3.5.2, and I noticed a change in the behavior of 'Paste Special'. In the older version if I choose the option 'Format Only' the next time I use past special it will stick to what I set it to, being format only and whatever options I would set beside that. In this version if I use Paste Special again it will default back to 'Values Only' erasing not only the 'Format Only' but also any extra options that I have set. I think this is a bug and it should remember the settings you picked, so you don't have to keep setting it up every paste afterwards.

Steps to Reproduce:
1. Use Paste Special with 'Format Only'
2. Use Paste Special again and click OK immediately

Actual Results:
The second paste resulted in the default options of 'values only'

Expected Results:
The second paste should result in the same settings you picked on the first paste.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.3.5.2 (x64) / LibreOffice Community
Build ID: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: nl-NL (en_US); UI: en-US
Calc: CL
Comment 1 m.a.riosv 2022-08-26 16:59:59 UTC
Works for me
Version: 7.3.5.2 (x64) / LibreOffice Community
Build ID: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL
Comment 2 ayla.alhollandiyah 2022-08-27 08:49:08 UTC
I am sorry, I made a mistake in my steps to reproduce. I said at step 2 to press OK, but that works as expected, like the other comment said. The problem is actually when you press enter instead of OK. In the old version that had the exact same effect as OK, but in this version if you press ctrl-shift-C again it preselects "Values Only" with a blue border, and if you then press enter it takes that button for input instead of the OK button with the settings from before.
Comment 3 Rafael Lima 2022-08-31 22:21:16 UTC
I can reproduce when using Enter to apply the Paste Special for the second time. The issue is that the dialog does not remember the previously used preset.

Maybe we could save and restore the previously used preset in the document.

This is not a bug per se, but an enhancement request.
Comment 4 Heiko Tietze 2022-09-01 07:20:04 UTC
This has been implemented recently and is available in nightly builds.

*** This bug has been marked as a duplicate of bug 69750 ***