Bug 151010 - Font substitution message should tell which font is being used
Summary: Font substitution message should tell which font is being used
Status: RESOLVED DUPLICATE of bug 61134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Font-Substitution
  Show dependency treegraph
 
Reported: 2022-09-16 20:50 UTC by Rafael Lima
Modified: 2022-09-16 21:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Current tooltip for font substitution (107.69 KB, image/png)
2022-09-16 20:50 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2022-09-16 20:50:02 UTC
Created attachment 182511 [details]
Current tooltip for font substitution

When a font is being substituted in the document, the tooltip that informs this situation in the UI should tell which font is being used in its place.

For instance, in the attached image the tooltip says:

"The current font is not available and will be substituted."

However, by which font is it being substituted? What font is actually being used?

Hence, I would like to propose that this tooltip is changed to:

"The current font is not available and was substituted by XXXX."

Where XXXX is the name of the actual font being used. Also, I think that it makes more sense to write the sentence in the past tense (note the "was" in the new tooltip in contrast with "will" in the current one).
Comment 1 Aron Budea 2022-09-16 20:59:38 UTC
This looks like a dupe of bug 61134 to me. What do you think, Rafael?
Comment 2 Rafael Lima 2022-09-16 21:10:28 UTC
(In reply to Aron Budea from comment #1)
> This looks like a dupe of bug 61134 to me. What do you think, Rafael?

You're right Aron. It is indeed a duplicate of bug 61134. I had done some search but did not find this one.

I'm marking it as duplicate of bug 61134.

*** This bug has been marked as a duplicate of bug 61134 ***