Bug 151055 - Table is corrupted when vertical Text Orientation is enabled
Summary: Table is corrupted when vertical Text Orientation is enabled
Status: RESOLVED DUPLICATE of bug 150642
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2022-09-19 11:24 UTC by Kevin Suo
Modified: 2022-09-21 04:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2022-09-19 11:24:56 UTC
Steps to Reproduce:
1. New Writer, Table > Insert Table > Insert using the defaults.
2. Select the four table cells, right-click, Table Properties > Text Orientation > Vertical (Top to Bottom).
3. Click OK.

Current Result:
Table is rendered correctly in step 1, but goes to the left outside of the visible screen area in step 3.

Expected Result:
Table keeps at its original position and text orientation of the cells successfully changed to vertical.

Reproducible in
Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 2ea790200f5d915f88c6f78014d978ce8d91e33f
CPU threads: 8; OS: Linux 5.19; UI render: default; VCL: gtk3
Locale: zh-CN (zh_CN.UTF-8); UI: en-US
Build Platform: Fedora34@X64, Branch:master, bibisect-linux-64-7.4-CN
Calc: threaded

and
Version: 7.4.2.0.0+ / LibreOffice Community
Build ID: 3acd979a0ff308abe3d4ac62f7eb6bca4c59df4e
CPU threads: 8; OS: Linux 5.19; UI render: default; VCL: gtk3
Locale: zh-CN (zh_CN.UTF-8); UI: zh-CN
Calc: threaded

but now in 7.3 branch.
Comment 1 Kevin Suo 2022-09-19 11:36:00 UTC
Bibisected to range ae7efecd2..1bf82b26a which points to the following commit:

commit 1bf82b26aea3a403920a64cdfcb4671c947c7a01
Author: Mark Hung <marklm9@gmail.com>
Date:   Sun Aug 14 15:23:14 2022 +0800

    tdf#135991 fix unexpected hidden RTL sections.

It is noted that that commit was initially commited to 7.5+ was also backported to 7.4.1.

Adding Mark Hung to cc: could you please take a look? Thanks.
Comment 2 Kevin Suo 2022-09-21 04:57:24 UTC
Tested with a master build as of today and it seems fixed by  11ec622b8405dcaabc359e3d6e38c8a9142dad6b

*** This bug has been marked as a duplicate of bug 150642 ***