Bug 151087 - Expand "+" / fold "-" buttons poorly visible in dark mode, too small to be clear
Summary: Expand "+" / fold "-" buttons poorly visible in dark mode, too small to be clear
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.5.2 release
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.5.0 target:7.4.3
Keywords:
Depends on:
Blocks: Icon-Theme-Breeze Icon-Theme-Colibre Icon-Theme-Elementary Icon-Request Icon-Theme-Sifr Linux-Dark-Mode Windows-Dark-Mode
  Show dependency treegraph
 
Reported: 2022-09-20 14:19 UTC by Rafael Lima
Modified: 2022-10-13 06:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing the problem (36.92 KB, image/png)
2022-09-21 11:33 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2022-09-20 14:19:59 UTC
The attached image shows a screenshot of the file below [1] using kf5 in a dark theme in Plasma 5.25 (stock Breeze dark system theme and Breeze dark icon theme in LO).

[1] https://cgit.freedesktop.org/libreoffice/core/plain/sc/qa/unit/data/ods/outline.ods

Note that the "+" and "-" buttons for folding and unfolding are not visible. They have a dark gray color over a black background.

System info

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 35702fd6781542f5eefbd3710304ab9a25ac61fe
CPU threads: 16; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL threaded
Comment 1 V Stuart Foote 2022-09-21 11:25:06 UTC
attachment?

Also, no issue with recent master on Windows 10 with os/DE in Dark mode.
+ and - buttons are visible for Dark mode this build. With or without the Application Colors using LibreOffice Dark color theme.

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a3bbdfab809609bec3475613a918eda699fbdc29
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 2 Rafael Lima 2022-09-21 11:33:33 UTC
Created attachment 182599 [details]
Screenshot showing the problem

Here's what I see on my computer. The +/- buttons are barely visible.
Comment 3 V Stuart Foote 2022-09-21 11:41:54 UTC
OK, I see the same on the Windows build.

So issue is just the size of the glyph used to label the buttons for fold (-) and unfold (+).
Comment 4 Rafael Lima 2022-09-30 13:56:20 UTC
After looking into this issue, I found out that this is an icon theme problem.

Icons "sc/res/ou01.png" to "sc/res/ou12.png" do not have dark variants, hence the problem.

@Rizal can you please take care of this?
Comment 5 Rizal Muttaqin 2022-09-30 17:06:14 UTC
(In reply to Rafael Lima from comment #4)
> After looking into this issue, I found out that this is an icon theme
> problem.
> 
> Icons "sc/res/ou01.png" to "sc/res/ou12.png" do not have dark variants,
> hence the problem.
> 
> @Rizal can you please take care of this?

Yes, I can see that Breeze has no dark variant, even no light version.
Comment 6 Commit Notification 2022-10-02 22:53:19 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2156ac86f02344090ad95c85eaa95448e99ead38

tdf#151087 Colibre: Fix dark dan light Group & Ungroup Columns/Rows

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Timur 2022-10-03 11:52:27 UTC
What in case of using Automatic (Elementary) theme?
Comment 8 Commit Notification 2022-10-03 13:19:14 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bd84c33f4247219a2888f68edfa7b704ba320787

tdf#151087 Breeze: Fix dark dan light Group & Ungroup Columns/Rows

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Rafael Lima 2022-10-10 22:54:47 UTC
Verified with

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: d1707bc31261d16893c1f5240c803d283e293ec1
CPU threads: 16; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL threaded
Comment 10 Rizal Muttaqin 2022-10-12 09:17:08 UTC
Reopened since Sifr needs get fixed also
Comment 11 Rizal Muttaqin 2022-10-12 23:02:59 UTC
(In reply to Timur from comment #7)
> What in case of using Automatic (Elementary) theme?

elementary still fallbacked to Colibre. I can make elementary version if you wish.
Comment 12 Commit Notification 2022-10-12 23:57:59 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aca7edb4ca7fd58c50a6b64b472e80f2eb053fd5

tdf#151087 Sifr:+Grouped n Ungrouped Columns/Rows, Breeze: Revise it

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2022-10-13 04:35:04 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/81bda80a11bb3d6753fdc27629032886aa73a784

tdf#151087 elementary:Grouped n Ungrouped Columns/Rows

It will be available in 7.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2022-10-13 04:36:12 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b3869749719288e6d1951030f07dc3fbccc0c222

tdf#151087 elementary:Grouped n Ungrouped Columns/Rows

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2022-10-13 04:37:22 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/a1ca8d5bc68cc5f3090f3521e15f63c980b8fa3e

tdf#151087 Breeze, Colibre, Sifr:Grouped n Ungrouped Columns/Rows

It will be available in 7.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.