Bug 151130 - FILEOPEN DOC Table structure destroyed if cell with vertical text direction exists
Summary: FILEOPEN DOC Table structure destroyed if cell with vertical text direction e...
Status: RESOLVED DUPLICATE of bug 150642
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-22 13:01 UTC by Mark Tassoul
Modified: 2022-09-22 18:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Tassoul 2022-09-22 13:01:28 UTC
Description:
When I try to load .docx with Avery templates, screen is blank. Specifically using a template 5168 for shipping labels.  Same file on loads correct in MS Word

Actual Results:
I have multiple files for shipping labels Avery 5168.  Try to open multiple files for different addresses but nothing appears but a blank page.  Put same files on thumb drive, take to computer with MS Word and files open just fine

Expected Results:
No labels appear - just blank page


Reproducible: Always


User Profile Reset: No



Additional Info:
Open template with labels for modification
Comment 1 Buovjaga 2022-09-22 13:09:40 UTC
What is the origin of the docx, ie. what software produced it?
Please attach an example .docx.
If it contains information you can't share in public, consult https://wiki.documentfoundation.org/QA/Bugzilla/Sanitizing_Files_Before_Submission

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 Buovjaga 2022-09-22 18:07:02 UTC
The reporter emailed me a couple of .doc files that showed the problem. I bibisected the issue to https://git.libreoffice.org/core/commit/45e4abfed10aff768cd884ebcb1a38af0fea32d6

I noticed the issue is already fixed in bug 150642, so version 7.4.2 will have the fix. I confirmed the fix with a fresh build.

*** This bug has been marked as a duplicate of bug 150642 ***