Bug 151477 - Writer crashes when using Find/Replace dialog with japanese character.
Summary: Writer crashes when using Find/Replace dialog with japanese character.
Status: RESOLVED DUPLICATE of bug 151148
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-10-12 05:39 UTC by yuri.musashi.miwa.tamura
Modified: 2022-10-12 12:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (75.69 KB, image/jpeg)
2022-10-12 05:42 UTC, yuri.musashi.miwa.tamura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yuri.musashi.miwa.tamura 2022-10-12 05:39:58 UTC
Description:
Writer crashes when using Find/Replace dialog with japanese character.

Steps to Reproduce:
1. New Writer document
2. Type one japanese katakana character with dakuten or handakuten (e.g. ガ)
3. Open Find and Replace dialog (Ctrl+H)
4. Type same as in step 2 in the Find textbox
5. Uncheck "Match character width" if checked
6. Click "Find Next" several times

Actual Results:
Crash or freeze

Expected Results:
No crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.3.6.2 (x86) / LibreOffice Community
Build ID: c28ca90fd6e1a19e189fc16c05f8f8924961e12e
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: en-US
Calc: threaded

This bug is also in 7.4.1
7.2.7 works well
Comment 1 yuri.musashi.miwa.tamura 2022-10-12 05:42:06 UTC
Created attachment 182986 [details]
screenshot
Comment 2 Julien Nabet 2022-10-12 06:57:17 UTC
It may me think about tdf#151148 but here there's a crash.

Would it be possible you give a try to prerelease 7.4.2? (see https://www.libreoffice.org/download/download-libreoffice/?version=7.4.2)
Indeed, perhaps the fix of tdf#151148 may have fixed this one.
Comment 3 yuri.musashi.miwa.tamura 2022-10-12 11:37:03 UTC
I confirmed 7.4.2 RC2 works well. (Download link is still RC1. It was hard to find RC2. Please update the link)
Comment 4 Julien Nabet 2022-10-12 12:07:32 UTC
(In reply to yuri.musashi.miwa.tamura from comment #3)
> I confirmed 7.4.2 RC2 works well. (Download link is still RC1. It was hard
> to find RC2. Please update the link)

Thank you for your feedback.
I don't know who deals with this but anyway LO 7.4.2 should be officially released in just a few days (see https://wiki.documentfoundation.org/ReleasePlan/7.4)

*** This bug has been marked as a duplicate of bug 151148 ***