Bug 151786 - The formula bar in Calc is not displaying properly.
Summary: The formula bar in Calc is not displaying properly.
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2022-10-27 11:57 UTC by Tatsuhiko Shoji
Modified: 2024-06-17 03:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Formula bar is displayed in my system. (1.35 MB, image/png)
2022-10-27 11:59 UTC, Tatsuhiko Shoji
Details
Graphic test result. On my Intel UHD 730 (46.67 KB, application/x-zip-compressed)
2022-10-27 13:09 UTC, Tatsuhiko Shoji
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tatsuhiko Shoji 2022-10-27 11:57:31 UTC
Description:
I use LibreOffice calc in Windows 11 22H2 with system fonts modified.
In this environment, formula bar is displayed below than previous version.
I modify system fonts by No!! Meiryo UI.
https://github.com/Tatsu-syo/noMeiryoUI
No!! Meiryo UI changes system fonts by Windows API.
Now I use these fonts as system fonts.
Yu Gothic UI 9pt is title bar.
Other UI elements is IPA PGothic 10pt.
My display is 1920*1080 96 DPI.

Since Windows 8, user can't change system fonts nomally,
but Windows 7 with extended support can change system fonts.
Some user might occur this trouble.


Steps to Reproduce:
1.Launch calc with these system fonts. Title bar is Yu Gothic UI 9pt, other UI elements is IPA PGothic 10pt.


Actual Results:
Formula bar shows below than previous version.

Expected Results:
Formula bar shows upper as previous version and text box don't hided.


Reproducible: Always


User Profile Reset: No

Additional Info:
Yu Gothic UI isJapanese Windows system font.
IPA PGothic can download below.
https://moji.or.jp/ipafont/ipa00303/
Comment 1 Tatsuhiko Shoji 2022-10-27 11:59:21 UTC
Created attachment 183291 [details]
Formula bar is displayed in my system.
Comment 2 Tatsuhiko Shoji 2022-10-27 12:54:38 UTC
I reset myy profile.
But appearance problem still occures.
Comment 3 Tatsuhiko Shoji 2022-10-27 13:09:02 UTC
Created attachment 183293 [details]
Graphic test result. On my Intel UHD 730

I test graphic test.
73 tests succeed, 31 tests quirky, 5 tests excluded.
Comment 4 m_a_riosv 2022-10-27 13:12:18 UTC Comment hidden (obsolete)
Comment 5 ady 2023-11-30 10:53:44 UTC
This is not a duplicate of bug 149777.

Bug 149777 is about what is shown within the input window box in the formula bar.

Bug 151786 is about the location of the formula bar itself in reference to the rest of the UI.

By this time, bug 151786 might be already solved. It should be tested in a current version such as LO 7.6 or newer.
Comment 6 Stéphane Guillou (stragu) 2023-11-30 16:00:27 UTC
Thanks for catching that, Ady!
Looks like bug 153784, which was reported to have started in 7.4.
Tatsuhiko, please test again in version 7.6 and let us know if it is resolved.
Comment 7 QA Administrators 2024-06-17 03:15:54 UTC
Dear Tatsuhiko Shoji,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INSUFFICIENTDATA
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-NeedInfo-Ping