Bug 151879 - Opening a Base document a second time with macro executed after view has been created gives error message - no macro executed any more
Summary: Opening a Base document a second time with macro executed after view has been...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2022-11-03 20:09 UTC by Robert Großkopf
Modified: 2023-03-03 15:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Open the database. Macro will be executed. Close and open it again … (11.84 KB, application/vnd.oasis.opendocument.database)
2022-11-03 20:09 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2022-11-03 20:09:49 UTC
Created attachment 183397 [details]
Open the database. Macro will be executed. Close and open it again …

Open the attached database.
A macro will be executed.
First there is a messagebox, which shows: The macro has started and tries to open a form.
Then a form will be opened.
Close the form.
Close the Base file.
Open the Base file again.
Instead of executing the macro appears an Error:

com.sun.star.lang.DisposedException: Component is already disposed. at /home/buildslave/source/libo-core/dbaccess/source/core/inc/ModelImpl.hxx:471

This buggy behavior appears in LO 7.4.2.3. It doesn't appear in LO 7.3.6.2 and earlier versions of LO. So a regression.
Comment 1 Robert Großkopf 2022-11-03 20:11:43 UTC
Macro appears also with
Version: 7.4.0.3 / LibreOffice Community
Build ID: f85e47c08ddd19c015c0114a68350214f7066f5a
CPU threads: 6; OS: Linux 5.3; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
on OpenSUSE 15.3 64bit rpm Linux.
Seems it has ben introduced with LO 7.4
Comment 2 Buovjaga 2023-03-03 14:37:12 UTC
It works for me both with 7.4 and 7.5

Do you still see it with 7.5?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Arch Linux 64-bit, X11
Version: 7.5.1.2 (X86_64) / LibreOffice Community
Build ID: 50(Build:2)
CPU threads: 8; OS: Linux 6.2; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
7.5.1-1
Calc: CL threaded
Comment 3 Robert Großkopf 2023-03-03 15:21:33 UTC
(In reply to Buovjaga from comment #2)
> It works for me both with 7.4 and 7.5
> 
> Do you still see it with 7.5?
> 
> Set to NEEDINFO.
> Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED
> WORKSFORME, if the problem went away.

Don't see the buggy behavior under LO 7.4.6.1 and also 7.5.1.2 (but won't use this version for database - destroys border of text controls in forms, bug 152974)

So I will close this bug as WORKSFORME.