Bug 152015 - File hangs Writer during load.
Summary: File hangs Writer during load.
Status: RESOLVED DUPLICATE of bug 151736
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.2.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2022-11-12 14:49 UTC by ScootrKDEbug Richards
Modified: 2022-11-28 10:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File hangs Writer during load. (200.97 KB, application/vnd.oasis.opendocument.text)
2022-11-12 14:49 UTC, ScootrKDEbug Richards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ScootrKDEbug Richards 2022-11-12 14:49:11 UTC
Created attachment 183553 [details]
File hangs Writer during load.

Reference bug 151858:
     bug 151858 was filed from the crash reporting server and is 
     br-a3dea0ef-d335-4912-9708-a497e4de722a.
See also file attached to 151858 for sample that causes crash.
---
When loading 201K file saved from Writer 7.4.1.2, Writer appears to hang and must be terminated by task manager.
Writer was able to open other files of same age & Writer version (7.4.1.2). 
problem persists through windows restart and in Writer Safe Mode.
---
Version: 7.4.2.3 (x64) / LibreOffice Community
Build ID: 382eef1f22670f7f4118c8c2dd222ec7ad009daf
CPU threads: 2; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 1 Robert Großkopf 2022-11-12 15:57:56 UTC
Might be the same bug as  bug 151736. 
Have tested it with LO 7.4.2.3 - fails
Then tested with 
Version: 7.4.3.1 / LibreOffice Community
Build ID: 3793858a34d8fef5b92f8fee233f97766f05e281
CPU threads: 6; OS: Linux 5.3; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded
and the document will be loaded without any problem.

Please try with LO 7.4.3. If you won't wait (like me) you could download LO 7.4.3.1 for your system here:
https://dev-builds.libreoffice.org/pre-releases/win/x86_64/
Comment 2 Stéphane Guillou (stragu) 2022-11-12 16:51:16 UTC
Also opens fine with recent master build:

Version: 7.5.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 61d716901def607f01ab272996bf40b55642d650
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Let's see if reporter can confirm it is fixed!
Comment 3 ScootrKDEbug Richards 2022-11-12 17:41:13 UTC
I'd like to try, but newer than 7.4.2 is not available that I can see.
Windows won't let me install an older version until I uninstall 7.4.2, 
and I don't see a way to do that. (I'm a Linux user on safari in Msland).
Any tips, links, or ideas?
Comment 4 ScootrKDEbug Richards 2022-11-12 17:43:46 UTC
(In reply to ScootrKDEbug Richards from comment #3)
> I'd like to try, but newer than 7.4.2 is not available that I can see.
> Windows won't let me install an older version until I uninstall 7.4.2, 
> and I don't see a way to do that. (I'm a Linux user on safari in Msland).
> Any tips, links, or ideas?

PS: OH duh. will follow link you provided to 7.4.5
(Bugzilla is also new to me, and it is a bit bewildering at first.)
Comment 5 ScootrKDEbug Richards 2022-11-12 18:31:52 UTC
Installed 7.4.3.1, file loads successfully. Yeah! Thank you folks for all your quick help.
Comment 6 Robert Großkopf 2022-11-12 18:45:33 UTC
(In reply to ScootrKDEbug Richards from comment #5)
> Installed 7.4.3.1, file loads successfully. Yeah! Thank you folks for all
> your quick help.

So let us set this one as duplicate of bug 151736

*** This bug has been marked as a duplicate of bug 151736 ***
Comment 7 Commit Notification 2022-11-28 10:56:28 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/03b5ef45ae3485e055bbbf44532835a5f8868b8e

tdf#152015: sw_odfimport: Add unittest

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.