Bug 153895 - No page preview in Print dialog (kf5 / qt5)
Summary: No page preview in Print dialog (kf5 / qt5)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.5.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.6.0 target:7.5.2
Keywords: bibisected, bisected, regression
: 153980 154027 (view as bug list)
Depends on:
Blocks: KDE Print-Dialog
  Show dependency treegraph
 
Reported: 2023-03-01 07:44 UTC by Tohotom
Modified: 2023-03-07 13:42 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of the print dialog box (81.63 KB, image/png)
2023-03-01 07:44 UTC, Tohotom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tohotom 2023-03-01 07:44:49 UTC
Created attachment 185657 [details]
screenshot of the print dialog box

There is no page preview in the Print dialog box, even if the option is selected (see attachment).

To reproduce: open print dialog box. 

Expected behavior: there should be a preview of the printed document.

Os: Kde Neon, with Plasma 5.27.1, frameworks 5.103.0 and Qt 5.15.8.

LibreOffice 7.5.1.2, installed form LibreOffice PPA (fresh).
Comment 1 V Stuart Foote 2023-03-01 13:31:33 UTC
can't confirm on Windows builds

Print dialog shows well formed preview of Calc, Draw and Writer and modules. Where the dialog's preview matches the Print Preview mode Calc and Writer.

Version: 7.5.1.2 (X86_64) / LibreOffice Community
Build ID: fcbaee479e84c6cd81291587d2ee68cba099e129
CPU threads: 8; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 2 raal 2023-03-01 16:41:19 UTC
No repro with Version: 7.6.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 4e6ab75c1a907398d24768d19cf097a4892d374c
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 3 Stéphane Guillou (stragu) 2023-03-01 23:15:41 UTC
Can't repro in with gtk or gen VCLs, but I can with kf5:

Version: 7.5.1.2 (X86_64) / LibreOffice Community
Build ID: fcbaee479e84c6cd81291587d2ee68cba099e129
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Same with qt5 (qfont+xcb) and kf5 (cairo+wayland).

Regression, as I can't repro in:

Version: 7.4.5.1 / LibreOffice Community
Build ID: 9c0871452b3918c1019dde9bfac75448afc4b57f
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 4 Stéphane Guillou (stragu) 2023-03-01 23:26:48 UTC
Bisected with linux-64-7.5 repo to first bad commit 3715a9f25ed4675fba49ef7df7036c1b2ec853d5 which points to core commit:

commit 7a6cbff566122113b753fd31e7c73be8725f48f2
author	Michael Weghorn <m.weghorn@posteo.de>	Tue Jan 31 16:08:53 2023 +0100
committer	Michael Stahl <michael.stahl@allotropia.de>	Thu Feb 02 11:27:30 2023 +0000
tree baac257d57c51c86ea36cbb61ceaa13aa9450897
parent 52216e9aad59c6c43b47f3d29d73bde9d11280d3
tdf#152073 qt: Draw background when drawing frame
For native drawing of a frame (border), use
the window background color as default color.
[...]
Change-Id: I08e6d05d0fc3d0e54952a65cd28dee92615df0a3
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/146419

Michael, can you please have a look?
Comment 5 Michael Weghorn 2023-03-02 12:02:05 UTC
Pending Gerrit change:
https://gerrit.libreoffice.org/c/core/+/148117
Comment 6 Commit Notification 2023-03-02 16:27:57 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/699a1745f30cc0e89d59c6fc6ea742da5ff0ccea

tdf#152073 tdf#153895 basicide: Set bg color for border win

It will be available in 7.6.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 V Stuart Foote 2023-03-06 22:52:10 UTC
*** Bug 154027 has been marked as a duplicate of this bug. ***
Comment 8 V Stuart Foote 2023-03-06 22:53:47 UTC
*** Bug 153980 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2023-03-07 13:42:33 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-7-5":

https://git.libreoffice.org/core/commit/41570cf09b171a6ee1f04d39dd72399e2726d381

tdf#152073 tdf#153895 basicide: Set bg color for border win

It will be available in 7.5.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.