Bug 154730 - Enhancement: Consistent UI terminology for zooming
Summary: Enhancement: Consistent UI terminology for zooming
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
(earliest affected) release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
Keywords: difficultyMedium, easyHack, skillDesign, topicUI
Depends on:
Blocks: Zoom
  Show dependency treegraph
Reported: 2023-04-09 16:00 UTC by Don Matschull
Modified: 2023-04-12 03:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Don Matschull 2023-04-09 16:00:56 UTC
Tooltips, dialogs, and menu choices use several different terms to achieve the effect of showing the complete page in the Workspace in LibreOffice Draw.

The menu that appears when you right click on the percentage number at the right end of the Status Bar offers a choice of zooming to "Entire Page".

The Zoom & View Layout dialog that appears when you left click on this same percentage number at the right end of the Status Bar labels the choice as "Fit width and height".

The four-pointed arrow a little to the left in the Status Bar displays a tooltip that says: "Fit slide to current window."

If you go to View>Zoom, you're given a choice of "Entire Page".

If you go to the bottom of this same menu and select Zoom..., the Zoom & View Layout dialog opens that labels the choice as "Fit width and height".

The icon for this zoom factor shown in the Zoom toolbar displays a Tooltip that says "Entire Page".

Such use of various terminology can cause unnecessary confusion, especially when someone is first trying to learn how to use LibreOffice Draw. It can also lead people to believe LibreOffice Draw is more complicated and hard to learn than is actually the case.

Describing the same action in consistent terminology would be a major improvement.
Comment 1 V Stuart Foote 2023-04-09 17:45:38 UTC
Agree the labeling of the "Entire Page", "Fit [slide|page] to current window", "Fit width and height" could all be consolidated, I think functionally they are all equal--though different code paths I'd imagine. 

Would suggest the "Fit width and height" to be the most appropriate across the modules.

The residual "Slide" labeling in Draw are those of bug 150477 and your bug 154732
Comment 2 Heiko Tietze 2023-04-11 09:30:06 UTC
The command .uno:ZoomPage uses the label "Entire Page", which is suggested to change into "Fit width and height". When changing this label one should check the places where it's used, eg. the label might be too long for the notebookbar and needs a contextual version or alias. Therefore medium difficult.

Something for you, Seth?