Bug 156085 - LibreOffice hangs at start, frequent crashes
Summary: LibreOffice hangs at start, frequent crashes
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
Keywords: wantBacktrace
Depends on:
Reported: 2023-06-28 06:41 UTC by jan
Modified: 2024-03-25 16:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

WinDbg backtrace and version info (2.61 KB, text/plain)
2023-07-03 08:49 UTC, jan
WinDbg backtrace (14.48 KB, text/plain)
2023-07-04 09:22 UTC, jan
skia.log (37 bytes, text/plain)
2023-07-04 12:49 UTC, jan

Note You need to log in before you can comment on or make changes to this bug.
Description jan 2023-06-28 06:41:31 UTC
We have 3 Windows 11 systems with Version
At  the first start after starting the system the small LibreOffice start window stops when the progress bar reaches about 30 %.
After closing the program in the task manager, LibreOffice starts normally at the second try.
I have reset my user settings and disabled hardware acceleration without success.
The program also crashes much more often in normal use than in previous versions.

Steps to Reproduce:
1.Start LibreOffice
2.Start window hangs

Actual Results:
No response of the program

Expected Results:
Normal start

Reproducible: Always

User Profile Reset: Yes

Additional Info:
Normal start
Comment 1 Julien Nabet 2023-06-28 08:15:12 UTC
Any better with LO 7.5.4 ?
Comment 2 Julien Nabet 2023-06-28 09:15:53 UTC
Response sent in private: "no, unfortunately not."

(Please next time respond on the bugtracker by using this link https://bugs.documentfoundation.org/show_bug.cgi?id=156085# so the information is shared.)

Thank you for the feedback, I don't have more questions here.
Comment 3 Stéphane Guillou (stragu) 2023-07-01 17:07:33 UTC
Do you see a crash reporter dialog when restarting LO? If so, please share the crash report link.

Please also share the detailed version info copied from Help > About LibreOffice.

If you don't get a crash report, it would be helpful to get a backtrace for that crash. If you have the time, please follow these steps: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 4 jan 2023-07-03 08:49:24 UTC
Created attachment 188170 [details]
WinDbg backtrace and version info

Version: (X86_64) / LibreOffice Community
Build ID: 36ccfdc35048b057fd9854c757a8b67ec53977b6
CPU threads: 12; OS: Windows 10.0 Build 22621; UI render: Skia/Vulkan; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 5 QA Administrators 2023-07-04 03:13:50 UTC Comment hidden (obsolete)
Comment 6 Julien Nabet 2023-07-04 08:51:32 UTC
The windbg trace shows nothing. Once you did "g" to indicate "go", you must try to reproduce a crash.
Once it crashes, you must type 
!analyze -v
to retrieve an useful stacktrace.
Comment 7 jan 2023-07-04 09:22:12 UTC
Created attachment 188205 [details]
WinDbg backtrace
Comment 8 Julien Nabet 2023-07-04 11:13:23 UTC
Argh, the stack only contains this:
00000000`00000000 00000000`00000000 soffice.bin!unknown_function+0x0
which can't help I suppose.

I must recognize I'm stuck here.
Comment 9 Stéphane Guillou (stragu) 2023-07-04 11:54:31 UTC
Please also provide the Skia log: https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_(_Skia_)

And test if the issue is Skia-related by using "Force Skia software rendering" in Tools ▸ Options ▸ LibreOffice ▸ View

Thank you!
Comment 10 jan 2023-07-04 12:49:53 UTC
Created attachment 188206 [details]

skia.log inncludes only 2 lines
disabling/enabling of "Force Skia software rendering" does not solve the problem.
Comment 11 QA Administrators 2023-07-05 03:14:04 UTC Comment hidden (obsolete)
Comment 12 Stéphane Guillou (stragu) 2023-07-05 15:08:04 UTC
Right, thank you.

Moving on to other ideas:
- please check that all updates for drivers and OS are installed
- try completely uninstalling LO, including removing the user profile, and reinstalling

Still no luck? Are the three devices exactly the same hardware?
Comment 13 jan 2023-07-06 09:32:46 UTC
Resetting profile and reinstallation we have tried without success.
We have 3 different computers, two of them Win 11, one Win 10.
Comment 14 Roman Kuznetsov 2023-07-08 11:53:42 UTC
jan, what hardware do you use? CPU and GPU? Could you try to start LibreOffice in Safe mode using main menu item for it?
Comment 15 RicoEm 2023-09-26 10:46:44 UTC Comment hidden (spam)
Comment 16 QA Administrators 2024-03-25 03:13:28 UTC
Dear jan,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INSUFFICIENTDATA
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

Comment 17 Klexus 2024-03-25 13:33:06 UTC
Even though it's somewhat an old version, the issue smells like as this one: https://bugs.documentfoundation.org/show_bug.cgi?id=157135#