Bug 158257 - ^{ opens the accessibility check
Summary: ^{ opens the accessibility check
Status: RESOLVED DUPLICATE of bug 151059
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.6.0.3 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-11-17 22:14 UTC by lillsascha
Modified: 2023-11-24 19:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lillsascha 2023-11-17 22:14:17 UTC
Description:
Whenever I type the combination of the two symbols "^{" on my German keyboard, an accessibility check window opens automatically and interrupts the typing process.

I then need to click into the editor in order to continue typing.

Steps to Reproduce:
1. Use a German Keyboard for Windows
2. Open LibreOffice Writer
3. Type the two characters "^{"

Actual Results:
On the screen, I see "^{", an accessibility check window opens and typing is interrupted.

Expected Results:
On the screen, I see "^{".


Reproducible: Always


User Profile Reset: No

Additional Info:
-
Comment 1 V Stuart Foote 2023-11-18 13:03:24 UTC
Can't confirm with en-US keyboard -- the "^{" can be entered.
 
Version: 7.6.2.1 (X86_64) / LibreOffice Community
Build ID: 56f7684011345957bbf33a7ee678afaf4d2ba333
CPU threads: 8; OS: Windows 10.0 Build 19045; UI render: default; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

But isn't this the same <AltGr> issue as bug 151059, already changed for 24.2.0 and the 7.6.3 releases where the Sidebar deck shortcuts have been changed to simple <Alt>+[1-9]--but now causing bug 158112 for Windows use of the <Alt>+Numpad character input.

Please retest on 7.6.3 rc1, or on a nightly against 24.2.0 -- or when 7.6.3 is released in a week.
Comment 2 V Stuart Foote 2023-11-24 19:05:56 UTC

*** This bug has been marked as a duplicate of bug 151059 ***