Bug 159120 - Recent documents: Show only documents from the current module by default
Summary: Recent documents: Show only documents from the current module by default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.6.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:24.8.0 inReleaseNotes:24.8
Keywords:
Depends on:
Blocks: Recent-Document-List User-Profile
  Show dependency treegraph
 
Reported: 2024-01-11 06:52 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2024-06-14 11:00 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Current state of the MRU documents (31.22 KB, image/png)
2024-01-11 18:53 UTC, Andreas Heinisch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2024-01-11 06:52:34 UTC
Proposal: Switch the config option "ShowCurrentModuleOnly" to true by default.

Reason: We should treat individual LO modules as such.
Suggesting spreadsheets in Writer's recent document list confuses the user.

Start center shows all recent documents while the lists in Writer, Calc, Impress, etc should only show the types supported by the current module.
Comment 1 Heiko Tietze 2024-01-11 09:04:47 UTC
-0.5 from my side, more opinions please.
Comment 2 Heiko Tietze 2024-01-11 09:08:05 UTC
Public poll at https://fosstodon.org/@libodesign/111736524074789979
Comment 3 V Stuart Foote 2024-01-11 12:37:17 UTC
ODF workflows are better supported with MRU showing its full 25 item default from all modules. Filtering the MRU by active module (and shifting the shown entries to follow the active module) in practice forces you to keep all the modules open just to see the full MRU.

MRU does better as a simple stack, with some ability to pin and optionally sort by module.

-1
Comment 4 Stéphane Guillou (stragu) 2024-01-11 15:24:03 UTC
ShowCurrentModuleOnly is available since LO 7.6 with 6836776fa295293c114c267bca38d18603993a54 for bug 56696.
Comment 5 m_a_riosv 2024-01-11 16:19:13 UTC
I don't know if it could be possible to show the files for the same module at the beginning, It is like if there were filtered, but we can see all files.
Comment 6 Andreas Heinisch 2024-01-11 18:53:07 UTC
Created attachment 191881 [details]
Current state of the MRU documents

What about increasing the number of prepended documents in the MRU?
Comment 7 graham 2024-01-11 23:18:59 UTC
Sorry first time trying to use mastodon so I can respond to your poll. I created an account at mindly.social thinking that would let me participate (since it's federated) but it looks like I would have to have an account on fosstodon.org to login and vote. 

Can someone give me a tip please?
Comment 8 Stéphane Guillou (stragu) 2024-01-12 08:23:06 UTC
(In reply to graham from comment #7)
> Sorry first time trying to use mastodon so I can respond to your poll. I
> created an account at mindly.social thinking that would let me participate
> (since it's federated) but it looks like I would have to have an account on
> fosstodon.org to login and vote. 
> 
> Can someone give me a tip please?
Try logging into mindly.social and put the URL https://fosstodon.org/@libodesign/111736524074789979 in the search box. That shouĺd lead you to the poll from the perspective of your server. (If it has reached it.)
Comment 9 Heiko Tietze 2024-01-12 10:55:40 UTC
(In reply to V Stuart Foote from comment #3)
> ODF workflows are better supported with MRU showing its full 25 item default...
While I basically agree, changing the default is not the end of the world. In fact it kind of promotes the start center since you would still see documents from all modules there (unless you filter).
Comment 10 V Stuart Foote 2024-01-12 15:28:30 UTC
(In reply to Heiko Tietze from comment #9)
> (In reply to V Stuart Foote from comment #3)
> > ODF workflows are better supported with MRU showing its full 25 item default...
> While I basically agree, changing the default is not the end of the world.
> In fact it kind of promotes the start center since you would still see
> documents from all modules there (unless you filter).

No real objection to increasing MRU history default, but I think for on launch performance we may need to implement enhancement of bug 99716 to clean up the profile .XCU, and refactor the MRU objects as needed.
Comment 11 Heiko Tietze 2024-01-18 09:13:06 UTC
(In reply to Heiko Tietze from comment #2)
> Public poll at https://fosstodon.org/@libodesign/111736524074789979

Poll has ended and users are somewhat split, as usual, but the majority appreciates the change. 

41% for "Keep showing all documents in the MRU" vs. 59% for "Show only documents from the current module" (out of 491 responses in total).

One idea is worth to consider as a compromise:

"I also thought of a submenu item "Other files >" in the module's MRU menu item, but then the user will lose the context of the current module, which would cause confusion as this is unexpected behaviour." (Sven Puschmann)
Comment 12 Commit Notification 2024-01-18 10:14:41 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ca704f49ea82dd69e0df059f6a80214fb77f026d

tdf#159120 Show only documents from the current module by default

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Samuel Mehrbrodt (allotropia) 2024-01-18 10:22:36 UTC
Thanks all!

I would suggest as a follow up fix to adjust the number of documents displayed as described in bug 159257.
Comment 14 V Stuart Foote 2024-01-18 13:15:55 UTC
(In reply to Commit Notification from comment #12)
> Samuel Mehrbrodt committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/commit/
> ca704f49ea82dd69e0df059f6a80214fb77f026d
> 
> tdf#159120 Show only documents from the current module by default
> 
> It will be available in 24.8.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

@Samuel, Heiko, *
So the change simply toggles the 'ShowCurrentModuleOnly' setting from False to True, and can be changed back from Expert Configuration..., works as expected.

Unfortunately there is no corresponding adjustment of the MRU History handling for the 'Clear List'. Which now will delete non-visible MRU items (and their thumbnails) from profile.

Seems like the 'Clear List' is going to need to be tweaked to respond only to current module as well.
Comment 15 Heiko Tietze 2024-01-18 15:01:24 UTC
Another follow-up like bug 159257, IMO.
Comment 16 V Stuart Foote 2024-03-21 16:41:45 UTC
(In reply to Commit Notification from comment #12)

So just bitten by this gem.

A bit of QA work teasing out diff between Writer handling of paragraph Styles and Draw handling of text attributes in a drawing shape style (missing Fixed line spacing for bug 145081).  Closed the drawing to review its .fodg then back into LO (Writer still open) and attempted to open from MRU recent file list--not there!

Racked my brain for a bit. Oh, wait--I now have to toggle expert config 'ShowCurrentModuleOnly' to expose all recent documents.  Hmm, is this really an improvement to UX?
Comment 17 V Stuart Foote 2024-03-21 16:43:21 UTC
Huh, BZ now *auto-Reopens* on comment. Huh?
  
Back to fixed...
Comment 18 Stéphane Guillou (stragu) 2024-03-21 23:45:02 UTC
(In reply to V Stuart Foote from comment #17)
> Huh, BZ now *auto-Reopens* on comment. Huh?
History shows you reopened on 18th of January, for the issue in comment 14 I assume?

(In reply to V Stuart Foote from comment #16)
> Racked my brain for a bit. Oh, wait--I now have to toggle expert config
> 'ShowCurrentModuleOnly' to expose all recent documents.  Hmm, is this really
> an improvement to UX?
I'm also a bit unsure now that the change is live. But I respect the results of the poll.
Now that it's the default, wondering if a way forward, so that list is not a dead end, could be one of:

- sub-submenu titled "other file types" or something of the sort, with files from other components (overengineering?); or
- prioritising bug 77590 so we can add a link to the Start Center from that menu.
Comment 19 V Stuart Foote 2024-03-22 01:51:59 UTC
(In reply to Stéphane Guillou (stragu) from comment #18)
> History shows you reopened on 18th of January, for the issue in comment 14 I
> assume?

OK, didn't remember reopening this--wasn't too keen on it. Now I know why.
Comment 20 burnuser2 2024-05-06 09:38:51 UTC
It's a real shame!
OpenOffice / LibreOffice was every time very proud about a major advantage over Microsoft Office: The Integration of it's different modules!

And now, after many years, somebody think's: "Hey, how can we make the life of many people a lot harder? - Let's remove the integration of modules!"

But what is the new solution, if I resume the work on a calc table and want - in parallel - resume the work on an according writer report? Or a presentation?
Open a new document (which is not needed) only to get the according list of recent used documents?
Who on earth can present this "new workflow" as improvement?
A complication without any reason!
Why???

And no, the - very good - hidden expert option to get a reasonable workflow back is no sufficient solution!
Comment 21 Heiko Tietze 2024-05-06 10:12:24 UTC
(In reply to burnuser2 from comment #20)
> And no, the - very good - hidden expert option to get a reasonable workflow
> back is no sufficient solution!
What argument do you have to keep the all-in-one concept? Just legacy is not much, and there are some voice here to have it changed (see comment 2).
Comment 22 Justin L 2024-06-13 13:09:35 UTC
I don't understand the connection to "start center". That only shows up when you do not have any documents open at all. "Recent Documents" is used when you already have one document open and want to open a second "recent" document. Now I have to "start a new document" in the other application and "open recent document" from there - especially annoying for Impress which prompts for a template choice.

I'm very sad to see this implemented.
Comment 23 Heiko Tietze 2024-06-14 06:00:55 UTC
(In reply to Justin L from comment #22)
> I'm very sad to see this implemented.
ShowCurrentModuleOnly is your friend :-)
Comment 24 Justin L 2024-06-14 11:00:59 UTC
(In reply to Heiko Tietze from comment #23)
> ShowCurrentModuleOnly is your friend :-)
Yes it is. I already added it to the "sample OXT configuration extension that accompanies the guide" at https://wiki.documentfoundation.org/Development/Extension_Development