Bug 160387 - Writer 7.6 and above versions freezes and crashes everytime
Summary: Writer 7.6 and above versions freezes and crashes everytime
Status: RESOLVED DUPLICATE of bug 157135
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2024-03-27 08:28 UTC by Erim
Modified: 2024-03-27 20:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Erim 2024-03-27 08:28:17 UTC
I'm using Windows 11 Pro. 7.5.9 works fine but if I install v7.6 or newer versions (example 24.2.1), Writer crashes immediately as soon as I navigate in any menu (for ex: page properties)
Spreadsheet works fine...

I searched the help pages, some people submitted the same. Many people suggested to close hardware accelators for graphics, or disable virus scanner's randomware, or change language to US English... I tried all of them but didn't work. WRITER CRASHED EVERTIME EVEN IN SAFE-MODE...
So I had install again.
It's the same on my both Windows 11 computers.

Steps to Reproduce:
1.format menu
2.select page style

Actual Results:
Writer freezes and not responds. Must force to quit from windows task manager

Expected Results:
should work normally

Reproducible: Always

User Profile Reset: Yes

Additional Info:
Somehow, works pretty fine but 7.6 and above crashes in the same way.
Comment 1 Stéphane Guillou (stragu) 2024-03-27 10:35:59 UTC
Hi Erim. Which locale do you use? Wondering if this is the same as bug 157135.
Can you please paste here the info from Help > About LibreOffice? There's a button to copy it.
Comment 2 Erim 2024-03-27 10:48:07 UTC

Yes, It's the similar with bug #157135.

Since I downgraded the version, I'm unable to send you "Help > About LibreOffice?".
I used all the versions above all were the same. Only 7.5 does not crash.
Comment 3 Stéphane Guillou (stragu) 2024-03-27 11:53:16 UTC
Please still share the detailed version information from 7.5.9, to see the language / locale info.

You can also test the upcoming versions 7.6.6 or 24.2.2, which have the fix for bug 157135, to see if it is indeed solved. Find them at the bottom of this page: https://www.libreoffice.org/download/download-libreoffice/
Comment 4 Erim 2024-03-27 12:35:36 UTC
Version: (X86_64) / LibreOffice Community
Build ID: bf759d854b5ab45b6ef0bfd22e51c6dc4fb8b882
CPU threads: 12; OS: Windows 10.0 Build 22631; UI render: Skia/Vulkan; VCL: win
Locale: tr-TR (tr_TR); UI: en-US
Calc: threaded

I installed as per your suggestion. It's working fine. Thank you.
Comment 5 Stéphane Guillou (stragu) 2024-03-27 20:52:40 UTC
Thank you for confirming! Let's mark as duplicate then.

*** This bug has been marked as a duplicate of bug 157135 ***