Download it now!
Bug 30961 - Animation related rendering glitches in Impress when Hardware Acceleration is disabled
Summary: Animation related rendering glitches in Impress when Hardware Acceleration is...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-18 06:14 UTC by Gökçen Eraslan
Modified: 2013-06-26 09:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Snapshot of black glitches (35.18 KB, image/png)
2010-10-18 06:18 UTC, Gökçen Eraslan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gökçen Eraslan 2010-10-18 06:14:29 UTC
Hello,

When I try attached presentation file, I see some annoying black regions around the items during the presentation show. I can reproduce this problem every time I try but, with the same distro(Pardus) and packages(libreoffice 3.2.99.1), when I try in a different machine with a different display card (Nvidia Quadro Fx) it is diplayed very well.
Comment 1 Gökçen Eraslan 2010-10-18 06:16:50 UTC
Since file is bigger than 1M I couldn't upload it, here is the link: 

http://cekirdek.pardus.org.tr/~gokcen/files/oo/deneme.odp
Comment 2 Gökçen Eraslan 2010-10-18 06:18:54 UTC
Created attachment 39507 [details]
Snapshot of black glitches
Comment 3 Gökçen Eraslan 2010-10-18 06:20:54 UTC
By the way I've tried some environment variables like:

SAL_DISABLE_NATIVE_ALPHA=1 OOO_FORCE_DESKTOP=gnome LIBGL_ALWAYS_SOFTWARE=1 SAL_USE_VCLPLUGIN=gtk SAL_ANTIALIAS_DISABLE=true SAL_DISABLE_BITMAPS_OPTS=1 SAL_ENABLE_GLX_XFREE4=1 ooimpress deneme.odp

but it didn't work.
Comment 4 Muthu 2010-10-20 13:12:33 UTC
Would it be possible for you to attach the (sample) document, please? So that we can reproduce it easily here?

Hardware related information would also be useful...


Thank you!
Comment 5 Gökçen Eraslan 2010-10-21 09:17:33 UTC
(In reply to comment #4)
> Would it be possible for you to attach the (sample) document, please? So that
> we can reproduce it easily here?
> 

The document was very big, so I've cut it down to a single slide. But it's still 4M and I couldn't upload it since upload is limited to files <= 1M. Document is here[1], you can download and try.

> Hardware related information would also be useful...
> 

I'm using Xorg server 1.9, display card is Intel Mobile GM965/GL960. If you need anything I can provide more info.

> 
> Thank you!

[1] http://cekirdek.pardus.org.tr/~gokcen/files/oo/deneme.odp
Comment 6 Thorsten Behrens (CIB) 2010-10-22 05:08:12 UTC
Hi Gökcen, just played with it (sadly only nvidia here currently) - and indeed it does not show. Could you please try to disable hardware acceleration in Tools->Options->View? Does the bug persist?

Independently, I see that cropped images are no longer cropped in slideshow - do you see the same?
Comment 7 Gökçen Eraslan 2010-10-23 03:31:49 UTC
(In reply to comment #6)
> Hi Gökcen, just played with it (sadly only nvidia here currently) - and indeed
> it does not show.

I'm sorry I didn't understand what you mean by 'does not show'. Is that the slide itself is not shown, or the black regions I mentioned?

> Could you please try to disable hardware acceleration in
> Tools->Options->View? Does the bug persist?
> 

Hardware Acceleration option is disabled here. Is that depends on a build option or an additional patch I've missed in patches/dev300/apply?

> Independently, I see that cropped images are no longer cropped in slideshow -
> do you see the same?

Laptop is in the office so now I don't have that laptop but Monday, I'll capture a video about how the presentation is rendered to help you better.

Thank you for your response, by the way.
Comment 8 Gökçen Eraslan 2010-10-24 00:21:41 UTC
(In reply to comment #7)
 
> Laptop is in the office so now I don't have that laptop but Monday, I'll
> capture a video about how the presentation is rendered to help you better.

I can reproducing the issue with another laptop with Intel display card. Here is the capture:

http://cekirdek.pardus.org.tr/~gokcen/files/oo/impress.ogv
Comment 9 Thorsten Behrens (CIB) 2010-10-25 01:16:15 UTC
Hm. The HW accel option should be available when built with --enable-cairo. I wonder if that may be a build problem, could you try the linux binaries from documentfoundation.org to rule that out? I'll try it later on an Intel gfx machine - could you meanwhile list the pci ids of the boxes you tried this on (both working & non-working) - lspci | grep VGA ?
Comment 10 Gökçen Eraslan 2010-10-25 04:25:23 UTC
(In reply to comment #9)
> Hm. The HW accel option should be available when built with --enable-cairo. I
> wonder if that may be a build problem, could you try the linux binaries from
> documentfoundation.org to rule that out? 

Yes, in our package, LibreOffice is compiled with --disable-cairo, I don't know why. Now I'm compiling Beta2 version with --enable-cairo and --with-system-cairo, I will write results when it's finished. Also I'll try binary LibreOffice packages in a while.

I'll try it later on an Intel gfx
> machine - could you meanwhile list the pci ids of the boxes you tried this on
> (both working & non-working) - lspci | grep VGA ?

I've 2 laptops with Intel cards, both non-working. pci id of one of them is:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

And I've a desktop with Nvidia card, presentation works fine in it and pci id is:

01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GT] (rev a1)
Comment 11 Gökçen Eraslan 2010-10-25 05:53:43 UTC
(In reply to comment #9)
> Hm. The HW accel option should be available when built with --enable-cairo. I
> wonder if that may be a build problem, could you try the linux binaries from
> documentfoundation.org to rule that out? I'll try it later on an Intel gfx
> machine - could you meanwhile list the pci ids of the boxes you tried this on
> (both working & non-working) - lspci | grep VGA ?

I've compiled package with --enable-cairo and --with-system-cairo, now in Intel laptop, slideshow is displayed as expected, really great. But, when I disable hardware acceleration, slideshow is displayed as in old package, there are big black regions.

You may close the bug as invalid since this is related to packaging but, I think rendering glitches appeared when package is compiled with --disable-cairo or Hardware Acceleration disabled, is also worth fixing.

Thank you.
Comment 12 Roman Eisele 2012-05-03 08:33:55 UTC
This is an Impress bug, therefore changed Component accordingly.
Comment 13 ign_christian 2013-06-05 16:10:45 UTC
This bug has not been touched by for a long time. 
Just confirming, is this bug still ASSIGNED?
Comment 14 Thorsten Behrens (CIB) 2013-06-05 19:37:47 UTC
The original links to the bugdocs have vanished, do you still have them somewhere Gökçen?
Comment 15 Gökçen Eraslan 2013-06-07 11:09:46 UTC
(In reply to comment #14)
> The original links to the bugdocs have vanished, do you still have them
> somewhere Gökçen?

Stupid me, no, it doesn't exist any more. Sorry about that. We can close it as INVALID, if you want.