Download it now!
Bug 31054 - folder with last file opened continue to be locked after file is closed
Summary: folder with last file opened continue to be locked after file is closed
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-22 12:23 UTC by Daniil Bratashov
Modified: 2013-03-21 12:31 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniil Bratashov 2010-10-22 12:23:12 UTC
On win32 systems Libreoffice block folder with last file accessed even when this file is closed until all LO apps are completelly closed or some file in another folder is opened. You cannot for example move or delete such folder without closing all opened LO instances.
Comment 1 Noel Power 2010-10-27 02:26:08 UTC
assigning to Tor
Comment 2 Don't use this account, use tml@iki.fi 2010-11-17 03:21:21 UTC
How did you open the document from the folder in question? From Explorer, by going to the folder in question and double-clicking or right-clicking? Or from inside LibreOffice?
Comment 3 Daniil Bratashov 2010-11-17 06:36:33 UTC
(In reply to comment #2)
> How did you open the document from the folder in question? From Explorer, by
> going to the folder in question and double-clicking or right-clicking? 

Problem is present when one uses explorer and double-click on file, or similarly start it from other file manager (Far manager, for example). 

Steps to reproduce:
* create folder
* put LO-supported file in the folder
* open this file by double click or similar way (so 'start "filename"' is actually executed)
* open some file in any other location
* close first file
* delete first file
* try to delete created folder

Problem is absent when one uses Explorer->Right click->Open with... and select LO app from list.

> Or from inside LibreOffice?

There is no such problem in this case.
Comment 4 Don't use this account, use tml@iki.fi 2010-11-17 06:44:02 UTC
Try putting a .txt file in the newly created folder, and double-click on that in Explorer. Notepad should open editing it. Then close the Explorer window showing the folder. Then open another file from Notepad. Then try to delete the folder.
Comment 5 Daniil Bratashov 2010-11-17 07:29:04 UTC
(In reply to comment #4)
> Try putting a .txt file in the newly created folder, and double-click on that
> in Explorer. Notepad should open editing it. Then close the Explorer window
> showing the folder. Then open another file from Notepad. Then try to delete the
> folder.

Yes it is working similar way, i.e. one cannot delete folder until notepad is closed.
Comment 6 Daniil Bratashov 2010-11-17 07:36:25 UTC
(In reply to comment #5)
> Yes it is working similar way, i.e. one cannot delete folder until notepad is
> closed.

So it can be marked not a bug, but the problem is that from user point of view Writer and Calc (for example) are different applications.
Comment 7 Don't use this account, use tml@iki.fi 2010-11-17 07:47:07 UTC
Well, if (as I expect) it is being the current directory of the LibreOffice processes that keeps the folder open, we could fix it trivially, by making the processes change directory when started to some other place, for instance the location of their .exe file, which will obviously always exist. Then there is maybe just the small issue of remembering the original current directory so that can be used as the default directory for file open dialogs.

This might even be classified as an "Easy Hack"?
Comment 8 Daniil Bratashov 2010-11-17 08:05:33 UTC
(In reply to comment #7)
> This might even be classified as an "Easy Hack"?

It is better idea, than marking "not a bug" :)
Comment 9 steve -_- 2013-02-21 16:16:51 UTC
Daniil: Is this still valid when using LO 4.0? Could you give that a try?
Comment 10 retired 2013-03-21 11:50:25 UTC
No further feedback for one month from bug reporter.

@Daniil: If this problem is still reproducible using LO 4, please re-open this bug.

If anybody else with Windows wants to test this, please give it a go.
Comment 11 Daniil Bratashov 2013-03-21 12:31:33 UTC
Seems to be fixed, sorry for delay. Tested on LO 4.0.0.3, win32, Vista