Download it now!
Bug 31162 - Cannot add new template in Writer
Summary: Cannot add new template in Writer
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-27 08:23 UTC by James Wilde
Modified: 2012-05-04 06:49 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Wilde 2010-10-27 08:23:03 UTC
I copied my profile from OOo 3.2.1 to the appropriate place for Lib0 3.3 beta.  After doing this, I created a new template with the name _Mandarin-template.ott.  This was a modified copy of an already existing template called Mandarin-template.ott from the OOo installation.

I found that my new template was not visible in the Template window, but was visible in the Organize templates window, where it was out of order.  Trying to move it to its place in alphabetical order produced the response "Cannot be copied.  Perhaps there is already a copy." or words to that effect.

I thought the problem might relate to the use of an underscore in the name, although I have several other templates moved over from OOo, which have an underscore as the first character, and all these I can see and access.  However, I created a new copy of the Mandarin-template.ott file, which I saved as Chinki-template.ott.  I cannot see this one either.  In other words, a newly created template stored in the correct place, cannot be seen in the Template window, only in the Organize window.
Comment 1 James Wilde 2010-10-27 08:25:49 UTC
I should have noted that my modified template with the name _Mandarin-template.ott, placed in the OOo template directory, could be seen and accessed in OOo.
Comment 2 Noel Power 2010-10-28 03:57:52 UTC
a couple of questions ?

a) can you give some details about how you copied your profile ( from where and where to ) 
b) are you using beta1 or beta2 ?
c) what happens if you don't copy the profile, e.g. start with no profile, add some templates ?
Comment 3 James Wilde 2010-10-28 08:39:25 UTC
On Oct 28, 2010, at 12:57 , bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=31162
> 
> Noel Power <nopower@novell.com> changed:
> 
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>  Status Whiteboard|                            |infoprovider:james.wilde@su
>                   |                            |nde-wilde.com
>           Keywords|                            |NEEDINFO
> 
> --- Comment #2 from Noel Power <nopower@novell.com> 2010-10-28 03:57:52 PDT ---
> a couple of questions ?
> 
> a) can you give some details about how you copied your profile ( from where and
> where to ) 

Copied /Users/James/Library/Application Support/OpenOffice.org/3/user to /Users/James/Library/Application Support/libreOffice/3.  Simple copy and paste command from the right-click menu.

> b) are you using beta1 or beta2 ?

beta 1

> c) what happens if you don't copy the profile, e.g. start with no profile, add
> some templates ?

When I start beta 1 without an OOo profile I get a different startup picture.  A window opens offering me Text Document, Spreadsheet, etc, and with an option bottom right "Templates".  Clicking on this the first time I got a message saying "Initializing Templates for first time" or similar, and then the Template window opened with a template I had put there before and forgotten, called Chinki-template.  This I opened and saved as _Mandarin-template.ott in the same directory.  I can now open templates either from this opening screen or from New/Templates, and I see the _Mandarin-template file and can open it.

The problem may be the fact that I have copied over my entire OOo profile, including that OOo opens with a text document and not this window showing all the choices.

I will now copy over all my templates from the previous profile, instead of copying over the entire profile and see what happens.  Later:  I can see them all and open both those that begin with a _ and those that begin with a letter.

So the problem lies somewhere else in the OOo profile, possibly that I configured OOo to start with a default document.
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 4 Noel Power 2010-10-29 02:46:37 UTC
(In reply to comment #3)
> On Oct 28, 2010, at 12:57 , bugzilla-daemon@freedesktop.org wrote:
> > a) can you give some details about how you copied your profile ( from where and
> > where to ) 
> 
> Copied /Users/James/Library/Application Support/OpenOffice.org/3/user to
> /Users/James/Library/Application Support/libreOffice/3.  Simple copy and paste
> command from the right-click menu.
ok this is the root of the problem, one should never do this, it is possible to copy some parts of the config profile individually if you really know what you are doing but really it's not recommended.
> 
> > b) are you using beta1 or beta2 ?
> 
> beta 1
configuration migration is presently something that is being discussed and is in general a problem even with upgrading between sun/oracle office installations
> 
> > c) what happens if you don't copy the profile, e.g. start with no profile, add
> > some templates ?
[...]
> So the problem lies somewhere else in the OOo profile, possibly that I
> configured OOo to start with a default document.
its not such that the problem is in the OOo profile but you sortof manual migration attempt. I will close this bug for now. Keep an eye on future versions, hopefully we will get better at handling the configuration profile migration business, thanks for the report and details
Comment 5 Roman Eisele 2012-05-04 06:49:48 UTC
This is a Writer issue (at the surface, even if the root of the problem is far more general and deeper, see comment #4), therefore changed the 'Component' field accordingly.

Set the 'Version' field according to original description and comment #3.