Download it now!
Bug 31182 - LibO Writer crashes when insert a formula from formula bar
Summary: LibO Writer crashes when insert a formula from formula bar
Status: RESOLVED DUPLICATE of bug 30921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-27 22:45 UTC by Yifan Jiang
Modified: 2012-05-04 07:02 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
crash stack (35.35 KB, text/x-log)
2010-10-27 22:45 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2010-10-27 22:45:05 UTC
Created attachment 39829 [details]
crash stack

Platform: SLED 11 sp1 i586
build info: LibreOffice 3.2.99.2 build 1

[Steps]

    1. Launch LibO Writer

    2. Press F2 to call out the formula bar

    3. type random legal formula in it ('=1' for example)

    4. Press Enter to insert
    
[Problem]

    LibO crashes when trying to insert the result
          
[Extra Information]

    - This is a regression to OO.o 3.2.1

    - Vanilla OO.o 3.3 does not have this problem

    - crash stack attached
Comment 1 Yifan Jiang 2010-10-27 22:45:50 UTC
Hi Cedric, not sure are you the right person for this? Please re-assign if not appropriate, thank you!
Comment 2 Cédric Bosdonnat 2010-10-28 02:50:48 UTC
Actually the same backtrace. The crash doesn't happen anymore in master

*** This bug has been marked as a duplicate of bug 30921 ***
Comment 3 Roman Eisele 2012-05-04 07:02:12 UTC
This is a Writer issue, just like bug 30921, therefore changed the 'Component' field accordingly.

The version must have been 3.3b2 (or so), see original description, date and bug 30921, therefore set 'Version' field to 3.3b2.