Download it now!
Bug 31272 - Cross-reference to bookmark is available after removing the bookmark
Summary: Cross-reference to bookmark is available after removing the bookmark
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-31 16:48 UTC by Rene Engelhard
Modified: 2012-08-31 10:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Pls see Comment 1! (9.58 KB, application/vnd.oasis.opendocument.text)
2011-01-30 03:50 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Engelhard 2010-10-31 16:48:56 UTC
From http://bugs.debian.org/602007:

--- snip ---
If a bookmark is deleted, the link to this bookmark points to a                 
non-existing reference.                                                         
This behaviour can be reproduced:                                               
- Create bookmark (Menu: Insert --> Bookmark...)                                
- Create cross-reference to this bookmark (Menu: Insert -->                     
Cross-reference...)                                                             
- Delete the bookmark and the text of the bookmark in the document              
The link is available in document and points to nothing.                        
After save and load of the document, the link is also available and             
points to nothing.                                                              
                                                                                
After changing the bookmark, it has to be asked what to do.   
--- snip ---
Comment 1 Rainer Bielefeld Retired 2011-01-30 03:49:40 UTC
NOT Reproducible with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag 3.3.0.4)]"

Steps to reproduce:
0. Open attached "Sample0.ods"
   On page 1 you find reference "below" to Bookmark "Mybookmark"
   In navigator you see Bookmark "Mybookmark"
1.  click on Reference "below" on page 1
   view will change to page 2 "Mybookmark"
2. Mark with mouse and delete 3 Lines from line above "Mybookmark" until  line
   below, watch Navigator
   as expected, Bookmark will disappear in navigator
3. Scroll to top of page 1
   report: reference will still exist
   actual: "Error, reference not found"

I believe this is a correct behavior, so I can't reproduce the problem

@Rene Engelhard:
Please specify your OS, Platform and LibO version (with what you observed the problem).
Can you still reproduce the problem with 3.3 release?
Comment 2 Rainer Bielefeld Retired 2011-01-30 03:50:57 UTC
Created attachment 42710 [details]
Pls see  Comment 1!
Comment 3 Rene Engelhard 2011-01-30 04:59:17 UTC
> @Rene Engelhard:
> Please specify your OS, Platform and LibO version (with what you observed the
> problem).

Please go read what I wrote. The info is is readily available. (Hint: There's a http link at the top)

Quoting that for you (unfortunately the submitter didn't specify the architecture, the system of course is debian testing/unstable), :

"Package: openoffice.org-writer
Version: 1:3.2.1-7
"

> Can you still reproduce the problem with 3.3 release?

Ask the submitter? I am just reporting here what got reported in the Debian BTS.
Comment 4 Rene Engelhard 2011-01-30 05:06:39 UTC
Rainer:

besides that it is questionable that you try anything I report/forward just with Windows or (as in 31271 where it explicitely was stated that it's a problem only when built against ICU 4.4). Everything I report is for Linux on Debian.

I just sent the submitter a mail cut'n'pasting your comment here, though.
Comment 5 Rene Engelhard 2011-01-30 05:13:09 UTC
oh, brilliant:

SMTP error from remote server after RCPT command:                                                                                                         
host mx00.kundenserver.de[212.227.15.169]:                                                                                                                
550 <bewoern@online.de>: invalid address
Comment 6 Rainer Bielefeld Retired 2011-02-04 10:47:58 UTC
Currently it seems to be not our bug, but something that Debian will have to fix?
Comment 7 Rene Engelhard 2011-02-04 13:15:11 UTC
if it doesn't happen with LibO (in the identical circumtances), yes.. 

(and it won't, the OOo version in squeeze won't be changed anymore except for really critical and security stuff) and for wheezy we'll just replace OOo with LibO :-)
Comment 8 Björn Michaelsen 2011-12-23 13:55:23 UTC
Replace whiteboard status "UNCONFIRMED" with a move to status "NEEDINFO" for unassigned new bugs.
Comment 9 Björn Michaelsen 2011-12-23 16:59:55 UTC
needinfo keyword redundant by needinfo status.
Comment 10 sasha.libreoffice 2012-01-13 01:46:19 UTC
reproduced on LibO 3.5.0 beta 1 on Fedora 64 bit
but where is written that links should be changed automatically. My be user want delete Bookmark in one pace and insert in another. And we can do Tools->Update->Update all.
Please, cite from LibreOffice help, that links should be changed automatically
Comment 11 Florian Reisinger 2012-08-14 13:57:20 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Florian Reisinger 2012-08-14 13:58:42 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 Florian Reisinger 2012-08-14 14:03:15 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 14 Florian Reisinger 2012-08-14 14:05:29 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian