Download it now!
Bug 31521 - Named range breaks when deleting a row
Summary: Named range breaks when deleting a row
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-10 05:20 UTC by Phil Hibbs
Modified: 2011-12-22 05:50 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Hibbs 2010-11-10 05:20:28 UTC
1. Select an entire column
2. Define it as a Named Range - by default it misses out the last row, so change
the definition to include row 1048576
3. Put a value in row 1048576
4. Do a VLOOKUP looking for the same value from another cell in the named range
5. Delete a blank row from the sheet
The VLOOKUP result will change to #N/A. The named range should have changed to
cover rows 1 to 1048575, and the value is in row 1048575, but the VLOOKUP fails
to find it.
Comment 1 Phil Hibbs 2010-11-10 05:24:29 UTC
Behaviour observed on Go-oo, will try on LibreOffice beta tonight.
OpenOffice.org 3.2.1 
OOO320m19 (Build:9505)
ooo-build 2010-07-18
Comment 2 Kohei Yoshida 2010-11-10 05:46:16 UTC
Hello Phil,

I can't reproduce this using the latest build of LibreOffice.  So, please try the latest beta of LibreOffice to see if the problem is still there.

BTW, I like your reporting style.  It's very easy to follow for us developers and help us try to reproduce the problem better. :-)
Comment 3 Kohei Yoshida 2010-11-10 05:54:31 UTC
I'll keep this bug in the meantimee.
Comment 4 Phil Hibbs 2010-11-10 07:59:03 UTC
Damn, it isn't doing it now! Same version, same process, the range is being created correctly (last row 1048576) and it doesn't break when I delete a row. I promise it was failing earlier! I can't think of anything I have done differently - maybe I had opened an Excel file earlier prior to creating a new ods spreadsheet. I'll try and replicate it again.
Comment 5 Kohei Yoshida 2011-04-01 21:33:23 UTC
Looks like no reproducible case has been provided.  Feel free to re-open if you find a way to reproduce this reliably.
Comment 6 Björn Michaelsen 2011-12-22 05:50:39 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.