Download it now!
Bug 31747 - broken debian files
Summary: broken debian files
Status: CLOSED DUPLICATE of bug 36275
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.4.0 Beta1
Hardware: All Linux (All)
: medium blocker
Assignee: Fridrich Strba
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-18 18:50 UTC by Sonic4Spuds
Modified: 2011-05-03 09:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip of edited control files in ${pkg}/debian/DEBIAN dir structure (1.63 KB, application/x-gzip)
2010-11-23 17:18 UTC, LeMoyne Castle
Details
3.4B2 install attempt log (14.15 KB, text/plain)
2011-04-25 10:26 UTC, NoOp
Details
LO34RC3 install/attempt log (53.14 KB, text/plain)
2011-04-30 14:35 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sonic4Spuds 2010-11-18 18:50:26 UTC
I realise that the debian files are not official builds, but they are completely unusable for English. All of the files install except any English language files (with extensions like en-us, en-gb, etc..). This is because of all but the most important one (this one installs) specified the main one with the wrong name (en-US instead of en-us). I would fix if I knew how but I have no experience with compiling or with programming on software with a user interface.

It would be great if someone could fix this (I'm attempting use in German (de) and have tried other languages without the localisation extension and they work fine.) :)  -Sonic4Spuds
Comment 1 Don't use this account, use tml@iki.fi 2010-11-19 03:14:42 UTC
*what* debian files? If they aren't provided from the official documentfoundation site, it is pointless to file a bug about them here. If you build LibreOffice yourself, and the build process is buggy, do file a bug. But resolving this one now, complain to whoever is providing the packages. Or just wait until there are official Debian packages of LibreOffice 3.3. Feel free to reopen this bug if you have more information and reason to believe the problem actually is in the LibreOffice source code.
Comment 2 Sonic4Spuds 2010-11-19 05:20:02 UTC
On 11/19/2010 05:14 AM, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=31747
>
> Tor Lillqvist<tlillqvist@novell.com>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>               Status|NEW                         |RESOLVED
>           Resolution|                            |NOTOURBUG
>
> --- Comment #1 from Tor Lillqvist<tlillqvist@novell.com>  2010-11-19 03:14:42 PST ---
> *what* debian files? If they aren't provided from the official
> documentfoundation site, it is pointless to file a bug about them here. If you
> build LibreOffice yourself, and the build process is buggy, do file a bug. But
> resolving this one now, complain to whoever is providing the packages. Or just
> wait until there are official Debian packages of LibreOffice 3.3. Feel free to
> reopen this bug if you have more information and reason to believe the problem
> actually is in the LibreOffice source code.
>
The files are provided on the document foundation website. They just 
have a note that says they are unofficial. Who else would I complain to, 
being that they are provided by the document foundation? Neither the 
site nor the file provide the name of the packager.

Thanks,
Sonic4Spuds
Comment 3 Don't use this account, use tml@iki.fi 2010-11-19 05:27:09 UTC
OK, reopening then and assigning to Fridrich. Or René?
Comment 4 LeMoyne Castle 2010-11-23 17:18:42 UTC
Created attachment 40525 [details]
Zip of edited control files in ${pkg}/debian/DEBIAN dir structure

I ran into this in October and again recently when trying to test the latest Beta of LibO.  I figured out how to get the debs to install.  
     Near as I can tell debian package dependencies are supposed to be all lower case.  Had to edit twelve DEBIAN/control files and almost all changes were "_US" to "-us".  Replaced underscore with dash, cap w/ lower and 33 w/ 3.3 in dependencies and the one package name.  Had to edit libreoffice3-en-us... control file to remove conflict with self  --  I also made changes in the replaces and provides statements there  --  ...  Made the cosmetic name change in the directory/deb name in the attachment (to: _3.3.0-12_).  
     I tested this solution by building all the packages (dpkg-deb) and installing them on Ubuntu Lucid and I now have a functioning LibO beta (able to open all apps, created db table, edited existing spreadsheet).  I had to manually remove a previous install of the "libreoffice3-en.." package to clear its self conflict and complete the install.  I had previously removed all of the other installed packages but that may or may not be necessary.
Comment 5 NoOp 2011-04-23 20:05:29 UTC
Same issues with 3.4B1 & B2. Following attempts to install 3.4B2 I had broken files:

$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  gthumb-data
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  libobasis3.4-base libobasis3.4-binfilter libobasis3.4-calc
  libobasis3.4-core02 libobasis3.4-core03 libobasis3.4-core04
  libobasis3.4-core05 libobasis3.4-core06 libobasis3.4-core07
  libobasis3.4-draw libobasis3.4-en-us libobasis3.4-en-us-base
  libobasis3.4-en-us-binfilter libobasis3.4-en-us-calc libobasis3.4-en-us-math
  libobasis3.4-en-us-res libobasis3.4-en-us-writer
  libobasis3.4-gnome-integration libobasis3.4-graphicfilter
  libobasis3.4-images libobasis3.4-impress libobasis3.4-javafilter
  libobasis3.4-kde-integration libobasis3.4-math libobasis3.4-ooofonts
  libobasis3.4-ooolinguistic libobasis3.4-pyuno libobasis3.4-testtool
  libobasis3.4-writer libobasis3.4-xsltfilter libreoffice3 libreoffice3-base
  libreoffice3-calc libreoffice3-dict-en libreoffice3-dict-es
  libreoffice3-dict-fr libreoffice3-draw libreoffice3-en-us
  libreoffice3-impress libreoffice3-math libreoffice3-writer
0 upgraded, 0 newly installed, 41 to remove and 1 not upgraded.
41 not fully installed or removed.
After this operation, 346MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  gthumb-data
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  libobasis3.4-base libobasis3.4-binfilter libobasis3.4-calc
  libobasis3.4-core02 libobasis3.4-core03 libobasis3.4-core04
  libobasis3.4-core05 libobasis3.4-core06 libobasis3.4-core07
  libobasis3.4-draw libobasis3.4-en-us libobasis3.4-en-us-base
  libobasis3.4-en-us-binfilter libobasis3.4-en-us-calc libobasis3.4-en-us-math
  libobasis3.4-en-us-res libobasis3.4-en-us-writer
  libobasis3.4-gnome-integration libobasis3.4-graphicfilter
  libobasis3.4-images libobasis3.4-impress libobasis3.4-javafilter
  libobasis3.4-kde-integration libobasis3.4-math libobasis3.4-ooofonts
  libobasis3.4-ooolinguistic libobasis3.4-pyuno libobasis3.4-testtool
  libobasis3.4-writer libobasis3.4-xsltfilter
0 upgraded, 0 newly installed, 30 to remove and 1 not upgraded.
30 not fully installed or removed.
After this operation, 311MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 467043 files and directories currently installed.)
Removing libobasis3.4-base ...
Removing libobasis3.4-binfilter ...
Removing libobasis3.4-calc ...
Removing libobasis3.4-core02 ...
Removing libobasis3.4-core03 ...
Removing libobasis3.4-core04 ...
Removing libobasis3.4-core05 ...
Removing libobasis3.4-core06 ...
Removing libobasis3.4-core07 ...
Removing libobasis3.4-draw ...
Removing libobasis3.4-en-us-res ...
Removing libobasis3.4-en-us-calc ...
Removing libobasis3.4-en-us-writer ...
Removing libobasis3.4-en-us-binfilter ...
Removing libobasis3.4-en-us-base ...
Removing libobasis3.4-en-us-math ...
Removing libobasis3.4-en-us ...
Removing libobasis3.4-gnome-integration ...
Removing libobasis3.4-graphicfilter ...
Removing libobasis3.4-images ...
Removing libobasis3.4-impress ...
Removing libobasis3.4-javafilter ...
Removing libobasis3.4-kde-integration ...
Removing libobasis3.4-math ...
Removing libobasis3.4-ooofonts ...
Removing libobasis3.4-ooolinguistic ...
Removing libobasis3.4-pyuno ...
Removing libobasis3.4-testtool ...
Removing libobasis3.4-writer ...
Removing libobasis3.4-xsltfilter ...
Processing triggers for menu ...
$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  gthumb-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  gthumb-data
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
After this operation, 8,180kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 463788 files and directories currently installed.)
Removing gthumb-data ...
Processing triggers for gconf2 ...
Processing triggers for hicolor-icon-theme ...

Following a purge of all B1 & then installing B2 I had:

$ sudo dpkg -i *.deb
Selecting previously deselected package libobasis3.4-base.
(Reading database ... 463535 files and directories currently installed.)
Unpacking libobasis3.4-base (from libobasis3.4-base_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-binfilter.
Unpacking libobasis3.4-binfilter (from
libobasis3.4-binfilter_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-calc.
Unpacking libobasis3.4-calc (from libobasis3.4-calc_3.4.0-103_i386.deb) ...
Unpacking libobasis3.4-core01 (from
libobasis3.4-core01_3.4.0-103_i386.deb) ...
dpkg: error processing libobasis3.4-core01_3.4.0-103_i386.deb (--install):
 trying to overwrite '/opt/libreoffice/LICENSE.odt', which is also in
package libobasis3.3-core01 3.3.2-19
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Selecting previously deselected package libobasis3.4-core02.
Unpacking libobasis3.4-core02 (from
libobasis3.4-core02_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-core03.
Unpacking libobasis3.4-core03 (from
libobasis3.4-core03_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-core04.
Unpacking libobasis3.4-core04 (from
libobasis3.4-core04_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-core05.
Unpacking libobasis3.4-core05 (from
libobasis3.4-core05_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-core06.
Unpacking libobasis3.4-core06 (from
libobasis3.4-core06_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-core07.
Unpacking libobasis3.4-core07 (from
libobasis3.4-core07_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-draw.
Unpacking libobasis3.4-draw (from libobasis3.4-draw_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-en-us.
Unpacking libobasis3.4-en-us (from
libobasis3.4-en-us_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-en-us-base.
Unpacking libobasis3.4-en-us-base (from
libobasis3.4-en-us-base_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-en-us-binfilter.
Unpacking libobasis3.4-en-us-binfilter (from
libobasis3.4-en-us-binfilter_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-en-us-calc.
Unpacking libobasis3.4-en-us-calc (from
libobasis3.4-en-us-calc_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-en-us-math.
Unpacking libobasis3.4-en-us-math (from
libobasis3.4-en-us-math_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-en-us-res.
Unpacking libobasis3.4-en-us-res (from
libobasis3.4-en-us-res_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-en-us-writer.
Unpacking libobasis3.4-en-us-writer (from
libobasis3.4-en-us-writer_3.4.0-103_i386.deb) ...
Unpacking libobasis3.4-extension-mediawiki-publisher (from
libobasis3.4-extension-mediawiki-publisher_3.4.0-103_i386.deb) ...
dpkg: error processing
libobasis3.4-extension-mediawiki-publisher_3.4.0-103_i386.deb (--install):
 trying to overwrite
'/opt/libreoffice/share/extensions/wiki-publisher/Addons.xcu', which is
also in package libobasis3.3-extension-mediawiki-publisher 3.3.2-19
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libobasis3.4-extension-pdf-import (from
libobasis3.4-extension-pdf-import_3.4.0-103_i386.deb) ...
dpkg: error processing
libobasis3.4-extension-pdf-import_3.4.0-103_i386.deb (--install):
 trying to overwrite
'/opt/libreoffice/share/extensions/pdfimport/META-INF/manifest.xml',
which is also in package libobasis3.3-extension-pdf-import 3.3.2-19
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libobasis3.4-extension-presentation-minimizer (from
libobasis3.4-extension-presentation-minimizer_3.4.0-103_i386.deb) ...
dpkg: error processing
libobasis3.4-extension-presentation-minimizer_3.4.0-103_i386.deb
(--install):
 trying to overwrite
'/opt/libreoffice/share/extensions/presentation-minimizer/META-INF/manifest.xml',
which is also in package libobasis3.3-extension-presentation-minimizer
3.3.2-19
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libobasis3.4-extension-presenter-screen (from
libobasis3.4-extension-presenter-screen_3.4.0-103_i386.deb) ...
dpkg: error processing
libobasis3.4-extension-presenter-screen_3.4.0-103_i386.deb (--install):
 trying to overwrite
'/opt/libreoffice/share/extensions/presenter-screen/META-INF/manifest.xml',
which is also in package libobasis3.3-extension-presenter-screen 3.3.2-19
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libobasis3.4-extension-report-builder (from
libobasis3.4-extension-report-builder_3.4.0-103_i386.deb) ...
dpkg: error processing
libobasis3.4-extension-report-builder_3.4.0-103_i386.deb (--install):
 trying to overwrite
'/opt/libreoffice/share/extensions/report-builder/META-INF/manifest.xml', which
is also in package libobasis3.3-extension-report-builder 3.3.2-19
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Selecting previously deselected package libobasis3.4-gnome-integration.
Unpacking libobasis3.4-gnome-integration (from
libobasis3.4-gnome-integration_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-graphicfilter.
Unpacking libobasis3.4-graphicfilter (from
libobasis3.4-graphicfilter_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-images.
Unpacking libobasis3.4-images (from
libobasis3.4-images_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-impress.
Unpacking libobasis3.4-impress (from
libobasis3.4-impress_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-javafilter.
Unpacking libobasis3.4-javafilter (from
libobasis3.4-javafilter_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-kde-integration.
Unpacking libobasis3.4-kde-integration (from
libobasis3.4-kde-integration_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-math.
Unpacking libobasis3.4-math (from libobasis3.4-math_3.4.0-103_i386.deb) ...
Unpacking libobasis3.4-ogltrans (from
libobasis3.4-ogltrans_3.4.0-103_i386.deb) ...
dpkg: error processing libobasis3.4-ogltrans_3.4.0-103_i386.deb (--install):
 trying to overwrite
'/opt/libreoffice/basis3.4/share/config/soffice.cfg/simpress/transitions-ogl.xml',
which is also in package libobasis3.4-impress 3.4.0-103
Selecting previously deselected package libobasis3.4-ooofonts.
Unpacking libobasis3.4-ooofonts (from
libobasis3.4-ooofonts_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-ooolinguistic.
Unpacking libobasis3.4-ooolinguistic (from
libobasis3.4-ooolinguistic_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-pyuno.
Unpacking libobasis3.4-pyuno (from
libobasis3.4-pyuno_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-testtool.
Unpacking libobasis3.4-testtool (from
libobasis3.4-testtool_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-writer.
Unpacking libobasis3.4-writer (from
libobasis3.4-writer_3.4.0-103_i386.deb) ...
Selecting previously deselected package libobasis3.4-xsltfilter.
Unpacking libobasis3.4-xsltfilter (from
libobasis3.4-xsltfilter_3.4.0-103_i386.deb) ...
Preparing to replace libreoffice3 3.3.2-19 (using
libreoffice3_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3 ...
Preparing to replace libreoffice3-base 3.3.2-19 (using
libreoffice3-base_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-base ...
Preparing to replace libreoffice3-calc 3.3.2-19 (using
libreoffice3-calc_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-calc ...
Preparing to replace libreoffice3-dict-en 3.3.2-19 (using
libreoffice3-dict-en_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-dict-en ...
/opt/libreoffice/program/unopkg.bin: error while loading shared
libraries: libdeploymentmiscli.so: cannot open shared object file: No
such file or directory
Preparing to replace libreoffice3-dict-es 3.3.2-19 (using
libreoffice3-dict-es_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-dict-es ...
/opt/libreoffice/program/unopkg.bin: error while loading shared
libraries: libdeploymentmiscli.so: cannot open shared object file: No
such file or directory
Preparing to replace libreoffice3-dict-fr 3.3.2-19 (using
libreoffice3-dict-fr_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-dict-fr ...
/opt/libreoffice/program/unopkg.bin: error while loading shared
libraries: libdeploymentmiscli.so: cannot open shared object file: No
such file or directory
Preparing to replace libreoffice3-draw 3.3.2-19 (using
libreoffice3-draw_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-draw ...
Preparing to replace libreoffice3-en-us 3.3.2-19 (using
libreoffice3-en-us_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-en-us ...
Preparing to replace libreoffice3-impress 3.3.2-19 (using
libreoffice3-impress_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-impress ...
Preparing to replace libreoffice3-math 3.3.2-19 (using
libreoffice3-math_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-math ...
Preparing to replace libreoffice3-ure 1.7.0-19 (using
libreoffice3-ure_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-ure ...
Preparing to replace libreoffice3-writer 3.3.2-19 (using
libreoffice3-writer_3.4.0-103_i386.deb) ...
Unpacking replacement libreoffice3-writer ...
dpkg: dependency problems prevent configuration of libobasis3.4-base:
 libobasis3.4-base depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-base (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-binfilter:
 libobasis3.4-binfilter depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-binfilter (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-calc:
 libobasis3.4-calc depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-calc (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-core02:
 libobasis3.4-core02 depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-core02 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-core03:
 libobasis3.4-core03 depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-core03 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-core04:
 libobasis3.4-core04 depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-core04 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-core05:
 libobasis3.4-core05 depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-core05 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-core06:
 libobasis3.4-core06 depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-core06 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-core07:
 libobasis3.4-core07 depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-core07 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-draw:
 libobasis3.4-draw depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-draw (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-en-us:
 libobasis3.4-en-us depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-en-us (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-en-us-base:
 libobasis3.4-en-us-base depends on libobasis3.4-en-us; however:
  Package libobasis3.4-en-us is not configured yet.
dpkg: error processing libobasis3.4-en-us-base (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
libobasis3.4-en-us-binfilter:
 libobasis3.4-en-us-binfilter depends on libobasis3.4-en-us; however:
  Package libobasis3.4-en-us is not configured yet.
dpkg: error processing libobasis3.4-en-us-binfilter (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-en-us-calc:
 libobasis3.4-en-us-calc depends on libobasis3.4-en-us; however:
  Package libobasis3.4-en-us is not configured yet.
dpkg: error processing libobasis3.4-en-us-calc (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-en-us-math:
 libobasis3.4-en-us-math depends on libobasis3.4-en-us; however:
  Package libobasis3.4-en-us is not configured yet.
dpkg: error processing libobasis3.4-en-us-math (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-en-us-res:
 libobasis3.4-en-us-res depends on libobasis3.4-en-us; however:
  Package libobasis3.4-en-us is not configured yet.
dpkg: error processing libobasis3.4-en-us-res (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
libobasis3.4-en-us-writer:
 libobasis3.4-en-us-writer depends on libobasis3.4-en-us; however:
  Package libobasis3.4-en-us is not configured yet.
dpkg: error processing libobasis3.4-en-us-writer (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
libobasis3.4-gnome-integration:
 libobasis3.4-gnome-integration depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-gnome-integration (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
libobasis3.4-graphicfilter:
 libobasis3.4-graphicfilter depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-graphicfilter (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-images:
 libobasis3.4-images depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-images (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-impress:
 libobasis3.4-impress depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-impress (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-javafilter:
 libobasis3.4-javafilter depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-javafilter (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
libobasis3.4-kde-integration:
 libobasis3.4-kde-integration depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-kde-integration (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-math:
 libobasis3.4-math depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-math (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-ooofonts:
 libobasis3.4-ooofonts depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-ooofonts (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
libobasis3.4-ooolinguistic:
 libobasis3.4-ooolinguistic depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-ooolinguistic (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-pyuno:
 libobasis3.4-pyuno depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-pyuno (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-testtool:
 libobasis3.4-testtool depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-testtool (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-writer:
 libobasis3.4-writer depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-writer (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libobasis3.4-xsltfilter:
 libobasis3.4-xsltfilter depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
dpkg: error processing libobasis3.4-xsltfilter (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3:
 libreoffice3 depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
 libreoffice3 depends on libobasis3.4-core02; however:
  Package libobasis3.4-core02 is not configured yet.
 libreoffice3 depends on libobasis3.4-core03; however:
  Package libobasis3.4-core03 is not configured yet.
 libreoffice3 depends on libobasis3.4-core04; however:
  Package libobasis3.4-core04 is not configured yet.
 libreoffice3 depends on libobasis3.4-core05; however:
  Package libobasis3.4-core05 is not configured yet.
 libreoffice3 depends on libobasis3.4-core06; however:
  Package libobasis3.4-core06 is not configured yet.
 libreoffice3 depends on libobasis3.4-core07; however:
  Package libobasis3.4-core07 is not configured yet.
 libreoffice3 depends on libobasis3.4-images; however:
  Package libobasis3.4-images is not configured yet.
dpkg: error processing libreoffice3 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-base:
 libreoffice3-base depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
 libreoffice3-base depends on libobasis3.4-base; however:
  Package libobasis3.4-base is not configured yet.
dpkg: error processing libreoffice3-base (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-calc:
 libreoffice3-calc depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
 libreoffice3-calc depends on libobasis3.4-calc; however:
  Package libobasis3.4-calc is not configured yet.
dpkg: error processing libreoffice3-calc (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-dict-en:
 libreoffice3-dict-en depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
 libreoffice3-dict-en depends on libobasis3.4-core02; however:
  Package libobasis3.4-core02 is not configured yet.
 libreoffice3-dict-en depends on libobasis3.4-core03; however:
  Package libobasis3.4-core03 is not configured yet.
 libreoffice3-dict-en depends on libobasis3.4-core04; however:
  Package libobasis3.4-core04 is not configured yet.
 libreoffice3-dict-en depends on libobasis3.4-core05; however:
  Package libobasis3.4-core05 is not configured yet.
 libreoffice3-dict-en depends on libobasis3.4-core06; however:
  Package libobasis3.4-core06 is not configured yet.
 libreoffice3-dict-en depends on libobasis3.4-core07; however:
  Package libobasis3.4-core07 is not configured yet.
 libreoffice3-dict-en depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
dpkg: error processing libreoffice3-dict-en (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-dict-es:
 libreoffice3-dict-es depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
 libreoffice3-dict-es depends on libobasis3.4-core02; however:
  Package libobasis3.4-core02 is not configured yet.
 libreoffice3-dict-es depends on libobasis3.4-core03; however:
  Package libobasis3.4-core03 is not configured yet.
 libreoffice3-dict-es depends on libobasis3.4-core04; however:
  Package libobasis3.4-core04 is not configured yet.
 libreoffice3-dict-es depends on libobasis3.4-core05; however:
  Package libobasis3.4-core05 is not configured yet.
 libreoffice3-dict-es depends on libobasis3.4-core06; however:
  Package libobasis3.4-core06 is not configured yet.
 libreoffice3-dict-es depends on libobasis3.4-core07; however:
  Package libobasis3.4-core07 is not configured yet.
 libreoffice3-dict-es depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
dpkg: error processing libreoffice3-dict-es (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-dict-fr:
 libreoffice3-dict-fr depends on libobasis3.4-core01; however:
  Package libobasis3.4-core01 is not installed.
 libreoffice3-dict-fr depends on libobasis3.4-core02; however:
  Package libobasis3.4-core02 is not configured yet.
 libreoffice3-dict-fr depends on libobasis3.4-core03; however:
  Package libobasis3.4-core03 is not configured yet.
 libreoffice3-dict-fr depends on libobasis3.4-core04; however:
  Package libobasis3.4-core04 is not configured yet.
 libreoffice3-dict-fr depends on libobasis3.4-core05; however:
  Package libobasis3.4-core05 is not configured yet.
 libreoffice3-dict-fr depends on libobasis3.4-core06; however:
  Package libobasis3.4-core06 is not configured yet.
 libreoffice3-dict-fr depends on libobasis3.4-core07; however:
  Package libobasis3.4-core07 is not configured yet.
 libreoffice3-dict-fr depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
dpkg: error processing libreoffice3-dict-fr (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-draw:
 libreoffice3-draw depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
 libreoffice3-draw depends on libobasis3.4-draw; however:
  Package libobasis3.4-draw is not configured yet.
dpkg: error processing libreoffice3-draw (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-en-us:
 libreoffice3-en-us depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
 libreoffice3-en-us depends on libobasis3.4-en-us; however:
  Package libobasis3.4-en-us is not configured yet.
 libreoffice3-en-us depends on libobasis3.4-en-us-base; however:
  Package libobasis3.4-en-us-base is not configured yet.
 libreoffice3-en-us depends on libobasis3.4-en-us-calc; however:
  Package libobasis3.4-en-us-calc is not configured yet.
 libreoffice3-en-us depends on libobasis3.4-en-us-math; however:
  Package libobasis3.4-en-us-math is not configured yet.
 libreoffice3-en-us depends on libobasis3.4-en-us-res; however:
  Package libobasis3.4-en-us-res is not configured yet.
 libreoffice3-en-us depends on libobasis3.4-en-us-writer; however:
  Package libobasis3.4-en-us-writer is not configured yet.
dpkg: error processing libreoffice3-en-us (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-impress:
 libreoffice3-impress depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
 libreoffice3-impress depends on libobasis3.4-impress; however:
  Package libobasis3.4-impress is not configured yet.
dpkg: error processing libreoffice3-impress (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice3-math:
 libreoffice3-math depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
 libreoffice3-math depends on libobasis3.4-math; however:
  Package libobasis3.4-math is not configured yet.
dpkg: error processing libreoffice3-math (--install):
 dependency problems - leaving unconfigured
Setting up libreoffice3-ure (3.4.0-103) ...
dpkg: dependency problems prevent configuration of libreoffice3-writer:
 libreoffice3-writer depends on libreoffice3; however:
  Package libreoffice3 is not configured yet.
 libreoffice3-writer depends on libobasis3.4-writer; however:
  Package libobasis3.4-writer is not configured yet.
dpkg: error processing libreoffice3-writer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libobasis3.4-core01_3.4.0-103_i386.deb
 libobasis3.4-extension-mediawiki-publisher_3.4.0-103_i386.deb
 libobasis3.4-extension-pdf-import_3.4.0-103_i386.deb
 libobasis3.4-extension-presentation-minimizer_3.4.0-103_i386.deb
 libobasis3.4-extension-presenter-screen_3.4.0-103_i386.deb
 libobasis3.4-extension-report-builder_3.4.0-103_i386.deb
 libobasis3.4-ogltrans_3.4.0-103_i386.deb
 libobasis3.4-base
 libobasis3.4-binfilter
 libobasis3.4-calc
 libobasis3.4-core02
 libobasis3.4-core03
 libobasis3.4-core04
 libobasis3.4-core05
 libobasis3.4-core06
 libobasis3.4-core07
 libobasis3.4-draw
 libobasis3.4-en-us
 libobasis3.4-en-us-base
 libobasis3.4-en-us-binfilter
 libobasis3.4-en-us-calc
 libobasis3.4-en-us-math
 libobasis3.4-en-us-res
 libobasis3.4-en-us-writer
 libobasis3.4-gnome-integration
 libobasis3.4-graphicfilter
 libobasis3.4-images
 libobasis3.4-impress
 libobasis3.4-javafilter
 libobasis3.4-kde-integration
 libobasis3.4-math
 libobasis3.4-ooofonts
 libobasis3.4-ooolinguistic
 libobasis3.4-pyuno
 libobasis3.4-testtool
 libobasis3.4-writer
 libobasis3.4-xsltfilter
 libreoffice3
 libreoffice3-base
 libreoffice3-calc
 libreoffice3-dict-en
 libreoffice3-dict-es
 libreoffice3-dict-fr
 libreoffice3-draw
 libreoffice3-en-us
 libreoffice3-impress
 libreoffice3-math
 libreoffice3-writer

Who is doing the packages for the .deb files?
Comment 6 Christian Lohmaier 2011-04-25 01:12:08 UTC
Is the original problem still an issue? At least for rpm I cannot see any problem related to en-US vs en-us

The following prints a package's name and version, and the listed dependencies, and then filters by those conatining en-US, en-us or en_US, en_us (for beta2):

$ rpm -qp --queryformat "%{NAME}-%{VERSION}\n" --requires *.rpm  |grep -i en[-_]us |sort -u
libobasis3.4-en-US  
libobasis3.4-en-US-3.4.0
libobasis3.4-en-US-base  
libobasis3.4-en-US-base-3.4.0
libobasis3.4-en-US-binfilter-3.4.0
libobasis3.4-en-US-calc  
libobasis3.4-en-US-calc-3.4.0
libobasis3.4-en-US-math  
libobasis3.4-en-US-math-3.4.0
libobasis3.4-en-US-res  
libobasis3.4-en-US-res-3.4.0
libobasis3.4-en-US-writer  
libobasis3.4-en-US-writer-3.4.0
libreoffice3-en-US-3.4.0

i.e. all is matching up libobasis3.4-en-US is requested by one or more packages, and there is a package "libobasis3.4-en-US" with version 3.4.0. Same for the other packages.

Note that the problem in the last comment (same files in 3.3.x and 3.4 packages  causing conflicts is a different bug #36551)
Comment 7 NoOp 2011-04-25 10:26:36 UTC
Created attachment 46059 [details]
3.4B2 install attempt log

Thanks Christian. I purged 3.3 again this morning; attached is my log of the 3.4B2 install attempt afterwards.
Comment 8 NoOp 2011-04-25 10:29:19 UTC
Perhaps I should open a new bug report?
Comment 9 Michael Meeks 2011-04-28 03:56:39 UTC
The most interesting bug is:

Setting up libreoffice3-dict-en (3.4.0-103) ...
/opt/libreoffice/program/../basis-link/ure-link/bin/javaldx: symbol lookup error: /opt/libreoffice/ure/bin/../lib/libuno_cppuhelpergcc3.so.3: undefined symbol: _ZTIN9salhelper21SimpleReferenceObjectE, version UDK_3_0_0
/opt/libreoffice/program/unopkg.bin: symbol lookup error: /opt/libreoffice/program/../basis-link/program/libxcrli.so: undefined symbol: _ZN4cppu11OWeakObject12queryAdapterEv, version UDK_3_0_0
find: `/opt/libreoffice/./share/prereg/bundled': No such file or directory
Comment 10 NoOp 2011-04-30 14:33:38 UTC
OK. I finally had time to test LO3.4B3 .deb installs on multiple machines. I attempted/installed on the following:

1. 3 32bit machines running Ubuntu 10.10 
- 2.6.35-29-generic #51-Ubuntu SMP Fri Apr 15 17:13:54 UTC 2011 i686 GNU/Linux
- LibO_3.4.0beta3_Linux_x86_install-deb_en-US.tar.gz
- $ md5sum LibO_3.4.0beta3_Linux_x86_install-deb_en-US.tar.gz
4a6110d63a6cb8b0784427dd7b6e6cd9  LibO_3.4.0beta3_Linux_x86_install-deb_en-US.tar.gz This md5sum matches: <http://download.documentfoundation.org/libreoffice/testing/3.4.0-beta3/deb/x86/LibO_3.4.0beta3_Linux_x86_install-deb_en-US.tar.gz.mirrorlist>

All 32bit installs failed with symbol lookup errors (see the attached install logs).

2. 2 64bit installs - one with Ubuntu 11.04 and one with Ubuntu 10.10. Both installations work.
- LibO_3.4.0beta3_Linux_x86-64_install-deb_en-US.tar.gz

The 64bit packages work, but the 32bit packages fail. If I have time I'll also test the 32bit packages on Ubuntu 8.04 and 11.04, but I suspect that those will fail as well.
Comment 11 NoOp 2011-04-30 14:35:02 UTC
Created attachment 46200 [details]
LO34RC3 install/attempt log
Comment 12 Cor Nouws 2011-05-01 01:13:45 UTC
Ubuntu 10.10, 32 bits:

I installed both 3.4.0beta1 and beta3 according to this
  http://wiki.services.openoffice.org/wiki/Run_OOo_versions_parallel
and none of them starts. 
I.e. either starting soffice, swriter, scalc does not result in any activity.

Heard the same from others.
I always use that method of installing and never had problems before.
Comment 13 Cor Nouws 2011-05-01 01:52:39 UTC
Just searched and see that the problem I reported is bug 36275
Comment 14 TerryW 2011-05-02 14:06:43 UTC
Had this problem with RC1 and RC2. received the same errors as NoOp. Tried RC3 on virgin instalations of Ubuntu 11.04 and Xubuntu 11.04 with the same results. On Ubuntu, 3.3.2 was purged using sudo apt-get purge libreoffice*.*, then RC3 was installed using sudo dpkg -i *.deb. On the Xubuntu installation libreoffice is not pre-installed so I only used sudo dpkg -i *.deb.

On windows 7 RC3 installed with no problems.
Comment 15 TerryW 2011-05-02 14:11:31 UTC
Had this problem with Beta 1 and Beta 2, receiving the same errors as NoOp. Tried RC3 on virgin installations of Ubuntu 11.04 and Xubuntu 11.04 with the same results. On Ubuntu, LibO 3.3.2 was purged using sudo apt-get purge libreoffice*.*, then RC3 was installed using sudo dpkg -i *.deb.

On the Xubuntu installation libreoffice is not pre-installed so I only used sudo dpkg -i *.deb.

On windows 7 RC3 installed with no problems.
Comment 16 NoOp 2011-05-03 09:04:22 UTC
Marking as duplicate of 36275. Please see:
https://bugs.freedesktop.org/show_bug.cgi?id=36275#c33

*** This bug has been marked as a duplicate of bug 36275 ***
Comment 17 Christian Lohmaier 2011-05-03 09:43:38 UTC
Please don't flag mutating issues as duplicate, just close them instead.

Again the original description, the first what people read when looking at this bug is a conflict of en-US vs en-us - the other issue has nothing to do with it, but as none of the later reports sill show that error, I won't reopen this one, but close it right away.

(and if you got to scroll to read the whole comment, it's clear indication that it should have been an attachment :-))
Comment 18 NoOp 2011-05-03 09:59:35 UTC
Got it. Thanks.