Bug 31766 - Removing of Hyperlinks with Clear Direct Formatting inconsistent: works in Calc/Impress but not in Writer
Summary: Removing of Hyperlinks with Clear Direct Formatting inconsistent: works in Ca...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Unify-Across-Apps Clear-Formatting Hyperlink 32227
  Show dependency treegraph
 
Reported: 2010-11-19 08:07 UTC by Mateusz
Modified: 2017-08-11 21:11 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz 2010-11-19 08:07:45 UTC
Hello

In Writer 3.3 beta3 "Clear formatting" (and "Default formatting" from menu Format) doesn't work.
Comment 1 Don't use this account, use tml@iki.fi 2010-11-22 00:39:22 UTC
For Cedric?
Comment 2 Cor Nouws 2010-11-29 05:07:34 UTC
may I suggest to fix this before 3.3.0 release?
Comment 3 Mateusz 2010-11-29 09:29:57 UTC
In OOo 3.3 RC7 (m17) works well, so bug must be somewhere in LibO patches.
Comment 4 Cédric Bosdonnat 2010-11-30 05:55:21 UTC
This is intentional and part of the fix for this OpenOffice.org issue:
http://qa.openoffice.org/issues/show_bug.cgi?id=47893
Comment 5 Cor Nouws 2010-11-30 06:04:29 UTC
ah, thanks.
might well happen again in the nearby future, that changes are reported as bug ;-)
Comment 6 Mateusz 2010-11-30 08:48:17 UTC
So how can user remove links from content if "clear formatting" doesn't do that?
Comment 7 Mateusz 2010-11-30 09:11:28 UTC
I don't mean "remove hyperlink" from context menu because this method is time consuming (if we have many links in text).
Comment 8 Cor Nouws 2010-11-30 10:57:08 UTC
Hmm, applying Character style Default (to a selection) does not help.
I just see, that when I have a selection with more hyperlinks, click somewhere in the selection and chose: remove hyperlink, it works for all selected hyperlinks.

(Personally I would prefer two functions: 
 - Ctrl-M: remove all not style based-formatting
 - Ctrl-Shft-M: remove all not paragraph-style based-formatting
 ;-)
Comment 9 Rainer Bielefeld Retired 2010-12-07 08:10:46 UTC
[Reproducible] with "LibreOffice 3.3.0 RC1 - WIN XP English UI  [OOO330m17 (build 3.3.0.1)]", I see the intention, but it seems that some inconsistences are left, so that I reopen this bug until all aspects will have been discussed. At least HELP contents will have to be corrected, pls see 
<http://help.libreoffice.org/Common/Default_Formatting>
(may be we will have to open a second Bug for that)

In CALC "Default Formatting" still removes Hyperlinks

Should we not have a menu item in 'Edit' or 'Format' to remove Hyperlinks?
Comment 10 lindrix 2010-12-20 17:18:22 UTC
Here also. In the LibreOffice/BrOffice Writer the formatting of link isn´t clearing with paste button > only text nor right button mouse at remove link option, being need i change color for black and i remove underline. Only remove the "reference" of the link.
Comment 11 Mateusz 2010-12-29 11:37:40 UTC
>In CALC "Default Formatting" still removes Hyperlinks

This problem concerns Impress/Draw too.

Can We expect unified behaviour for whole suite before 3.3 released?
Comment 12 John Fisher 2011-12-05 11:32:46 UTC
Still broken in 3.3.4. Docs aren't changed either. Since this worked in OOO, and is very useful, I hope it will receive some higher priority.

I frequently cut and paste from Bugzilla into a document, and no I don't want to start using CSV instead.
Comment 13 A (Andy) 2013-05-06 20:26:46 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 14 retired 2013-12-18 20:24:48 UTC
Trying to make something of this bug. Wanted or unwanted behavior is the big question.

Help says: https://help.libreoffice.org/Common/Clear_Direct_Formatting

There's already is the option to right-click any hyperlink and select "remove hyperlink".

After discussion in the QA IRC channel with Mechtilde and Michael Stahl we came to the conclusion that the current behavior is intentional and complaint to what the help article says.

So closing as NOTABUG.
Comment 15 Michael Stahl (CIB) 2013-12-18 20:51:38 UTC
there are basically 2 different opinions about hyperlinks in documents:
1) hyperlink is a content entity, like a field or a frame
2) hyperlink is formatting, like "bold"

depending on how you see hyperlinks you may get different opinions :)

more generally (and as described in OOo issue 47893) there is a definite
use case for a "Clear Formatting" feature that removes only
hard formatting, and leaves character styles, hyperlinks etc. alone.

this should be the most visible, easily accessible "Clear Formatting"
thing in the UI.

for hyperlinks in particular there is a "Remove Hyperlink" option
in the context menu to get rid of it, and Cor points out in
comment #8 that this actually works on a selection too.

but i'm not at all opposed to add a separate "Clear More Formatting"
or whatever menu entry that would remove things like character styles
and possibly hyperlinks and rubies (don't forget those :) too;
that would be a valid enhancement request.

but i'm re-opening this because it says that hyperlink removal
is "inconsistent" - and that is true, in Impress and Calc
the hyperlinks are converted to plain text but not in Writer;
i think that Impress and Calc should be changed to work like Writer.

please file a separate enhancement bug for the "Clear More Formatting"
if you like.  and think of a better name :)
Comment 16 Joel Madero 2014-11-03 03:25:28 UTC
REOPENED is incorrect status for this one. Setting to NEW per comment 15 from Michael Stahl.
Comment 17 QA Administrators 2016-11-08 12:10:12 UTC Comment hidden (obsolete)
Comment 18 Cor Nouws 2017-01-16 21:17:23 UTC
(In reply to Michael Stahl from comment #15)

> but i'm re-opening this because it says that hyperlink removal
> is "inconsistent" - and that is true, in Impress and Calc
> the hyperlinks are converted to plain text but not in Writer;
> i think that Impress and Calc should be changed to work like Writer.

Still the same in current master

> please file a separate enhancement bug for the "Clear More Formatting"
> if you like.  and think of a better name :)

Should do that, yes. (ping..)
Comment 19 Thomas Lendo 2017-05-26 20:03:16 UTC
I've the same opinion of Michael Stahl in comment 15.

For me, hyperlinks are no formatting, they are text elements like a list and no style like red text color (beside the fact, that links have a specific character style - but deleting them would make links in text unfindable). Therefore please do not remove links or default link for. If the behavior is anywhere different, please change that to make it work like in Writer.
Comment 20 Yousuf Philips (jay) (retired) 2017-05-27 22:14:21 UTC
As hyperlinks in Writer are automatically converted to use the 'Internet Link' character style, there is no way for 'Clear Direct Formatting' to work with it. I think this can be closed as wonfix or wfm as i doubt the behaviour can be unified between apps.
Comment 21 Heiko Tietze 2017-05-28 09:09:42 UTC
Closing the ticket once again (nice history, btw) as NOTABUG since it wasn't filed as enhancement request. 

Following comment 15 the function "Remove Link" known in Writer should be introduced in Calc and Draw/Impress in order to convert links into ordinary text. Please file another ticket for this.
Comment 22 Cor Nouws 2017-08-11 21:11:13 UTC
(In reply to Heiko Tietze from comment #21)

> Following comment 15 the function "Remove Link" known in Writer should be
> introduced in Calc and Draw/Impress in order to convert links into ordinary
> text. Please file another ticket for this.

see bug 111707 and bug 102911

Now also Clear direct formatting in Calc and Impress should nót remove the Hyperlink?!