Download it now!
Bug 31860 - drag & drop slides leads to extremelly slow refresh and UI freeze
Summary: drag & drop slides leads to extremelly slow refresh and UI freeze
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
: 31905 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-23 02:53 UTC by Laurent Godard
Modified: 2012-09-24 08:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
a sample impress file (12.59 KB, application/vnd.oasis.opendocument.presentation)
2010-11-23 02:53 UTC, Laurent Godard
Details
gdb backtrace leading to freeze as requested (17.41 KB, text/x-log)
2010-11-23 03:15 UTC, Laurent Godard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2010-11-23 02:53:34 UTC
Created attachment 40502 [details]
a sample impress file

an impress document, with some slides

in the left pane, take a slide and drag it up and down across other slides from top to back and so on, during some seconds (say ten)
then release mouse button to drop it

at beginning on dragging, it is ok, the dashed rectangle follows the mouse
then it becomes slower and slower

the Ui is then not responding (and may crash OOo sometimes, not reproductible every time)
Comment 1 Thorsten Behrens (CIB) 2010-11-23 03:01:40 UTC
Reporter's system: ubuntu 10.04, xorg 7.5 with compiz
Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Comment 2 Laurent Godard 2010-11-23 03:15:44 UTC
Created attachment 40504 [details]
gdb backtrace leading to freeze as requested

no more anti-aliasing
Comment 3 Laurent Godard 2010-11-23 03:42:38 UTC
removing anti-aliasing, no more "slow" problem on dragging but UI freeze at dropping
Comment 4 Don't use this account, use tml@iki.fi 2010-11-23 04:05:49 UTC
Thorsten?
Comment 5 Thorsten Behrens (CIB) 2010-11-23 08:14:12 UTC
backtrace shows a problem with accessibility, reporter confirms Gnome accessibility is enabled.
Comment 6 Laurent Godard 2010-11-23 08:25:51 UTC
on ubuntu 10.04 (gnome), going to system > preferences > accessibility
yes it is enabled
Comment 7 Caolán McNamara 2010-11-23 08:30:05 UTC
We can assume LibreOffice beta3 right ?. a11y is riddled with these sort of things, especially impress/draw.
Comment 8 Laurent Godard 2010-11-23 08:36:06 UTC
yes beta3. experienced also on OOo and first versions of libroffice
Comment 9 Thorsten Behrens (CIB) 2010-11-25 04:38:52 UTC
*** Bug 31905 has been marked as a duplicate of this bug. ***
Comment 10 Thorsten Behrens (CIB) 2010-11-29 17:20:00 UTC
Fixed the drag slowness with commit 16346ec31ca555087088b5c3522ef5b3e8f6753a

Accessibility issue still remains. Let's have separate bugs next time.
Comment 11 Cor Nouws 2010-12-16 05:16:04 UTC
related to http://qa.openoffice.org/issues/show_bug.cgi?id=108267 ?
Comment 12 Thorsten Behrens (CIB) 2010-12-16 05:31:54 UTC
Regarding comment 11 - yes, I believe this is the same bug.
Comment 13 Julien Nabet 2012-09-22 21:49:07 UTC
On pc Debian x86-64 (testing updated today) + Gnome with 3.5 sources updated today, I don't reproduce the pb.
I don't use accessibility tool (at least I haven't done anything to setup it).

Laurent: do you still reproduce the problem with 3.5.X or 3.6.X version?
Comment 14 Laurent Godard 2012-09-24 07:49:17 UTC
on debian x86-64, libro 3.5.4.2
not reproduced
Comment 15 Julien Nabet 2012-09-24 08:39:09 UTC
Laurent: thank you for your feedback, I put the status to WFM.