Download it now!
Bug 32197 - Problem with Calc options
Summary: Problem with Calc options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-07 12:55 UTC by Jean-Baptiste Faure
Modified: 2011-04-30 09:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screencopy of Calc options under MacOS (82.58 KB, image/png)
2010-12-07 12:55 UTC, Jean-Baptiste Faure
Details
screencopy of LibO > General options panel (136.76 KB, image/png)
2010-12-07 21:02 UTC, Jean-Baptiste Faure
Details
Untranslated preferences strings (101.56 KB, image/png)
2011-01-05 08:20 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2010-12-07 12:55:15 UTC
Created attachment 40881 [details]
screencopy of Calc options under MacOS

Grid and Print option entry appear two times, the second being not translated.

More the corresponding option label is not translated.

Please have a look at screenshot.

Best regards. JBF
Comment 1 Kohei Yoshida 2010-12-07 15:01:28 UTC
This likely is the result of the calc options list not being translated for the French locale.  

RID_OFADLG_OPTIONS_TREE_PAGES.SID_SC_EDITOPTIONS 6 through 11 are the ones that need to be translated.

However, I do see them already translated for the 'fr' locale, so I don't know why we are getting this.

Sophie, do you see this in the Linux build, as well as the Windows build of RC1?  If so, then this may be a Mac build issue...
Comment 2 Kohei Yoshida 2010-12-07 15:02:05 UTC
Adding Thorsten to the mix since this *may* be a Mac build issue...
Comment 3 Jean-Baptiste Faure 2010-12-07 20:46:13 UTC
Sorry, I should have clarified that the problem does not occur on my Linux install (x86_64). So it is probably MacOs specific.

Best regards. JBF
Comment 4 Jean-Baptiste Faure 2010-12-07 21:02:47 UTC
Created attachment 40893 [details]
screencopy of LibO > General options panel
Comment 5 Jean-Baptiste Faure 2010-12-07 21:04:03 UTC
Comment on attachment 40893 [details]
screencopy of LibO > General options panel

Not sure that the problem is only for Calc options. Same problem in LibO > General panel. Please see the screencopy.

Best regards. JBF
Comment 6 Kohei Yoshida 2010-12-07 21:16:00 UTC
Thanks.

Then, I'll give this to Thorsten.
Comment 7 Kohei Yoshida 2010-12-07 21:18:32 UTC
Looks like the translations given in the lo-build-fr.po file are not applied at all in the mac build...
Comment 8 Alex Thurgood 2011-01-05 08:19:48 UTC
Confirming in RC2. Enclosed PNG snapshot.


Alex
Comment 9 Alex Thurgood 2011-01-05 08:20:53 UTC
Created attachment 41669 [details]
Untranslated preferences strings
Comment 10 Andras Timar 2011-04-30 09:03:47 UTC
This bug is quite old and I'm sure it has been fixed already. At least in LibreOffice 3.4 beta 3 these strings are translated. The problem with option list is handled in a general way for all languages (with English fallbacks) in 3.3.x and 3.4 and above.