Download it now!
Bug 32235 - Dictionaries are not installed properly
Summary: Dictionaries are not installed properly
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: Other Linux (All)
: medium blocker
Assignee: Petr Mladek
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-08 09:08 UTC by Marc Pare
Modified: 2011-12-23 15:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
patch that allows to enable internal and extenal dictionaries at the same time (1.22 KB, patch)
2010-12-10 10:19 UTC, Petr Mladek
Details
patch that enables the internal dictionaries for LibreOfficeLinux distro (733 bytes, patch)
2010-12-10 10:20 UTC, Petr Mladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Pare 2010-12-08 09:08:16 UTC
After installation, no dictionaries are installed. When a different language pack(s) is installed there is still no installed dictionary. The only way to get a spellcheck dictionary installed is to download from the OOo dictionary page. 

Here is a thread with more information: http://nabble.documentfoundation.org/LibreOffice-RC1-and-language-packs-on-Linux-Mandriva-2010-1-td2028000.html

Looking forward to a fix for this.

Thanks a lot for the help. It is most appreciated.

Marc
Comment 1 Caolán McNamara 2010-12-08 12:34:21 UTC
Uh huh. So checking this, that seems to be the case. (well actually I have 101 language pre-installed system spellcheckers detected, which might be why noone really noticed until now that we're not bundling any with the default rpms)

cmc->pmladek/fridrich: I guessing that the universal Linux rpms are generated via the distro-configs/LinuxOfficeLinux.conf.in which has --without-myspell-dicts in it ? Or is one of the others the one that's used for the universal rpms. The "inner" configure defaults them on IIRC so it looks like its togged off for the universal case. I guess we should toggle it on for the universal rpms to be consistent with the windows experience.
Comment 2 Petr Mladek 2010-12-09 11:55:30 UTC
Sigh, I see bootstrap/configure.in:

--- cut ---
if test "$WITH_MYSPELL_DICTS" = "NO"; then
  AC_MSG_CHECKING([whether to use dicts from external paths])
  if test -n "$with_system_dicts" -a "$with_system_dicts" = "yes"; then
--- cut ---

So, if we enable the built-in dictionaries, it will not longer search for the system dictionaries and other people will complain.

The internal dictionaries are installed as extensions, so both ways should work.
The code in components/lingucomponent/source/lingutil/lingutil.cxx looks promissing.

I am going to modify configure and try build with both enabled.
Comment 3 Petr Mladek 2010-12-10 10:19:54 UTC
Created attachment 40991 [details]
patch that allows to enable internal and extenal dictionaries at the same time

It just removes:

if test "$WITH_MYSPELL_DICTS" = "NO"; the
fi

and update indentation of the lines in between.
Comment 4 Petr Mladek 2010-12-10 10:20:44 UTC
Created attachment 40992 [details]
patch that enables the internal dictionaries for LibreOfficeLinux distro
Comment 5 Petr Mladek 2010-12-10 10:23:54 UTC
I have a clean test build. It worked as expected:

    + internal dictionaries were packaged to libreoffice3-dict-<lang> rpms and
      bundled with the related lang packs
    + the system paths, e.g. /usr/share/hunspell, were still search for more
      dictionaries

Caolan, could you please review the patches, so we could commit them to the libreoffice-3-3 branch?
Comment 6 Caolán McNamara 2010-12-10 12:12:58 UTC
Looks good to me, go for it
Comment 8 sophie 2011-01-15 04:05:25 UTC
Closing - Sophie