Bug 32364 - Add a "filter" to Insert > Field > Other > Cross reference tab
Summary: Add a "filter" to Insert > Field > Other > Cross reference tab
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Akshay Deep
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
: 81570 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-13 14:54 UTC by RGB
Modified: 2017-02-14 08:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RGB 2010-12-13 14:54:58 UTC
The cross reference system on Writer is really powerful, but it needs one important enhancement: if you have several headings (I have documents with more than 30) finding the one you want to cross-reference is difficult. To have a filter field where you can type a few characters to narrow the list would be a blessing.
Comment 1 Cédric Bosdonnat 2010-12-14 00:43:22 UTC
This could be an easy hack. The code of the whole tab page is located here:
http://opengrok.go-oo.org/xref/writer/sw/source/ui/fldui/fldref.cxx

However, it would be nice to think about a better UI for the whole fields dialog as there are quite a lot of stuffs to add or change there.
Comment 2 Björn Michaelsen 2011-12-23 11:34:55 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Björn Michaelsen 2011-12-23 12:57:14 UTC
An EasyHack should have been checked by developers and thus is confirmed regardless of age. Moving back to NEW from NEEDINFO again. Sorry for the hassle.
Comment 4 Florian Reisinger 2012-05-18 09:38:07 UTC
Deleted "Easyhack" from summary.
Comment 5 Björn Michaelsen 2013-10-04 18:47:23 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 6 QA Administrators 2014-10-23 17:31:45 UTC
Please read this message in its entirety before responding.

Your bug was confirmed at least 1 year ago and has not had any activity on it for over a year. Your bug is still set to NEW which means that it is open and confirmed. It would be nice to have the bug confirmed on a newer version than the version reported in the original report to know that the bug is still present -- sometimes a bug is inadvertently fixed over time and just never closed.

If you have time please do the following:
1) Test to see if the bug is still present on a currently supported version of LibreOffice (preferably 4.2 or newer).
2) If it is present please leave a comment telling us what version of LibreOffice and your operating system.
3) If it is NOT present please set the bug to RESOLVED-WORKSFORME and leave a short comment telling us your version and Operating System

Please DO NOT
1) Update the version field
2) Reply via email (please reply directly on the bug tracker)
3) Set the bug to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 7 Björn Michaelsen 2014-12-02 10:53:11 UTC
adding LibreOffice developer list as CC to unresolved Writer EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 8 Robinson Tryon (qubit) 2015-12-10 11:50:48 UTC
Migrating Whiteboard tags to Keywords: (easyHack)
Comment 9 Chris Sherlock 2016-02-01 20:52:20 UTC
Hi all, a decent stab at resolving this has been made in gerrit, I don't know the codebase well enough to confirm the enhancement though. If someone more knowledgeable than myself could review this, it would be greatly appreciated :-)

https://gerrit.libreoffice.org/#/c/21856/
Comment 10 Akshay Deep 2016-02-08 03:51:49 UTC
Hello, kindly review the following patch commited by me for this bug.

https://gerrit.libreoffice.org/#/c/22197/
Comment 11 Robinson Tryon (qubit) 2016-02-18 14:52:26 UTC
JanI is default CC for Easy Hacks (Add Jan; remove LibreOffice Dev List from CC)
[NinjaEdit]
Comment 12 Commit Notification 2016-02-19 09:45:05 UTC
akki95 committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bebd483511a0a83532dc37e76e8ba76a67dd921f

tdf#32364 - Add a "filter" to Insert > Field > Other > Cross reference tab

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Cor Nouws 2016-08-13 19:53:11 UTC
*** Bug 81570 has been marked as a duplicate of this bug. ***