Download it now!
Bug 32501 - Having additional characters in slide show in Impress for Hebrew slides
Summary: Having additional characters in slide show in Impress for Hebrew slides
Status: CLOSED DUPLICATE of bug 31243
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-18 12:25 UTC by Lior Kaplan
Modified: 2011-01-04 00:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The presentation (127.50 KB, application/vnd.ms-powerpoint)
2010-12-18 12:25 UTC, Lior Kaplan
Details
The slide in edit mode (280.05 KB, image/png)
2010-12-18 12:27 UTC, Lior Kaplan
Details
slide in slide show mode (libO) (298.39 KB, image/png)
2010-12-18 12:29 UTC, Lior Kaplan
Details
slide in slide show mode (OOo) (279.29 KB, image/png)
2010-12-18 12:31 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2010-12-18 12:25:24 UTC
Created attachment 41239 [details]
The presentation

I encountered a presentation in Hebrew, which has additional characters in slide show than in edit mode. The characters replace most of the space in the original strings, meaning the text is hard to read.

I couldn't reproduce the problem with OOo RC7, while it does happen in LibO RC1, both on Debian sid AMD64.

The file itself and screen shots (2nd slide) are attached.
Comment 1 Lior Kaplan 2010-12-18 12:27:48 UTC
Created attachment 41240 [details]
The slide in edit mode
Comment 2 Lior Kaplan 2010-12-18 12:29:47 UTC
Created attachment 41241 [details]
slide in slide show mode (libO)
Comment 3 Lior Kaplan 2010-12-18 12:31:21 UTC
Created attachment 41242 [details]
slide in slide show mode (OOo)
Comment 4 Netanel_H 2010-12-21 02:51:46 UTC
I couldn't reprocedure this issue in Libo-3.3rc1 on Ubunu 10.10, maybe it is a Debian reletaed bug?
Comment 5 Jan Holesovsky 2010-12-21 08:40:24 UTC
Caolan, Thorsten: Can it be caused by the recent cairo canvas related changes?
Comment 6 Caolán McNamara 2010-12-21 08:52:36 UTC
The "LibO vs OOo" difference is quite possibly just the different defaults for the backend. i.e. toggle tools->options->view->"use hardware acceleration" in either app and see if it makes a difference, which I bet it will.

bug 31243 was the one we fixed relatively recently around glyph substitution in cairo canvas
Comment 7 Caolán McNamara 2010-12-21 13:28:06 UTC
This looks good in master for me at the moment anyway. I'm pretty sure that was fixed *after* RC1 so I think we will have this fixed in RC2 which will be available soon. 

Please test in that in a few days and reopen if I'm wrong about this.

*** This bug has been marked as a duplicate of bug 31243 ***
Comment 8 Lior Kaplan 2011-01-01 01:05:44 UTC
Looks fine in RC2. Thanks.